[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Assertion error installing FC3

Here's how I solved this. YMMV of course....

The short answer:  I used cfdisk to read and write the disk
partition table back to disk. Then I could install FC3.

The long answer.....

I had the same problem trying to install Fedora Core 3 on one
of my PCs. It has one disk that had Windows 2000 and Fedora
Core 2 on it. I wanted to install FC3 on top of the FC2 partition
but I got the Assertion disk error you mentioned below and it
would NOT let me install. It threw me out of the install program!!!

This PC had had its disk re-imaged via Ghost recently. The Ghost
image had the dual boot (Win2K and FC2) setup and partitions. So my guess was that the partition table that the Ghost image rewrote was not readable by the FC3 install program. I've been
through so many disk partition issues...I'm practically an expert
by now. The sad truth is that there is no standard format for
disk partition tables. Some partition tools can read what other
partition tools have written, but there's no guarantee.

I've tried lots of partition tools from Windows to Partition Magic to parted to fdisk to sfdisk to cfdisk. CFDISK is by far
the best one. It writes the most compatible partition tables.

So I booted up this PC with Knoppix or Mepis (I forget which one)
and used cfdisk to read the partition table and write it back out
to disk. No changes were made to the defined partitions.

After rewriting the partition table with cfdisk, FC3 installed just fine without errors. And I could still boot
Windows 2000 also. So all is well now.

CAREFUL!! Messing with partition tables is risky stuff unless you
really know what you are doing and have everything backed up.



Still didn't work, got the same error.

-----Original Message-----
From: fedora-list-bounces redhat com [mailto:fedora-list-bounces redhat com]
On Behalf Of Rick Lim
Sent: Friday, November 26, 2004 10:47 AM
To: 'Bob Parnass, AJ9S'
Cc: Fedora List
Subject: RE: Assertion error installing FC3

Bob, MUCH appreciated, I'll give it a try tonite, it has been driving me
crazy as I have done a couple of clean installs on different machines with
out this same error.

Thanks again.

-----Original Message-----
From: Bob Parnass, AJ9S [mailto:usenet4 parnass org] Sent: Friday, November 26, 2004 7:44 AM
To: Rick Lim
Subject: re: Assertion error installing FC3


I read your posting in the Fedora-list archives.
I don't subscribe, so I can't post this response there.

When I upgraded from FC2 to FC3, I saw the same
error messages you saw about:

"Assertion(heads>0) at disk_dos.c: 485 in function probe_partion_for_geom()

A web search found an explanation and a solution at:


Apparently, the initial installation of FC2 damaged the disk
geometry due to a bug in FC2.   This interferes with upgrading
to FC3.

I applied the fix described in the LWN article and was able to
upgrade successfully from FC2 to FC3.

Hope this helps.
========================================================================= Bob Parnass, AJ9S GNU/Linux User http://parnass.com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]