[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

VPD Keys errors fixed on Shuttle SN95G5 XPC



Some of you may have noticed the errors flooding /var/log/messages:

eth0: -- ERROR --
        Class:  internal Software error
        Nr:  0x19e
        Msg:  Vpd: Cannot read VPD keys

This is problem stems from issues related to the checksum of the vpd keys
for the Marvel Yukon Gigabit ethernet device.  It turns out several
different motherboards with this lan device show the same error; one is
the ASUS K8V.  Asus eventually supplied a dos-executable patch which
solves the problem on their motherboard.  The catch is, it seems to work
on the SN95G5- at least for two machines I have tried recently, one a ver
1.2 and another a version 2.  The patch is located at:

http://www.asus.com/support/download/selectftp.aspx?l1_id=1&l2_id=20&l3_id=1&m_i
d=3&f_name=vpd_patch.zip~zaqwedc

extract the zip files, and boot with a dos disk.  Then execute "vpdwrite
-P as_vpd.raw"

This cured the problem for me.

good luck.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]