[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mplayer Frustrations



On Thu, 07 Jul 2005 20:16:44 -0400, C.Beamer wrote:

> Hi All,
> 
> I've tried to search the archives for similar posts, but the oldest
> post that comes up in a search is Sept. 2004.  I've sorted the
> archives by thread and still didn't find anything related to my
> problem.  So, I'm posting and I apologize if this has been asked before.
> 
> I am tearing my hair out by the roots and would prefer not to become
> bald!  I've installed Mplayer via yum.  I removed it and installed via
> source tarball.  I removed the files from the tarball installation and
> installed again vi yum.  It doesn't matter which way I do it, I have
> the same result.  Mplayer works, it produces sound, but I get no
> video, either with mplayer by itself or from within Firefox where I've
> installed the mplayerplug-in.  And yes, I've installed the fonts and
> the codecs.
> 
> I honestly don't know what the big deal is.  I had mplayer working
> just fine under FC3.  I love Fedora, but with all the quirks that I've
> struggled through with FC4, I almost wish I had never upgraded.
> 
> Does anyone have any ideas on this?
> 
> Regards,
> 
> Colleen

You got me worried! I tried mine on a .wmv file and it didn't work either,
but it did work on an avi, so I figured it must be a missing win32 codec.
And I looked at the mplayer output and there it was:

Opening video decoder: [dmo] DMO video codecs
Win32 LoadLibrary failed to load: wmv9dmod.dll, /usr/lib/win32/wmv9dmod.dll, /usr/local/lib/win32/wmv9dmod.dll
IMediaObject ERROR: 0x84ec5c9  could not open DMO DLL (0x0 : 0)
Failed to create DMO filter
ERROR: Could not open required DirectShow codec wmv9dmod.dll.
You need to upgrade/install the binary codecs package.
Go to http://mplayerhq.hu/homepage/dload.html
VDecoder init failed :(
Opening video decoder: [dmo] DMO video codecs
Win32 LoadLibrary failed to load: wmvdmod.dll, /usr/lib/win32/wmvdmod.dll, /usr/local/lib/win32/wmvdmod.dll
IMediaObject ERROR: 0x84ec5c9  could not open DMO DLL (0x0 : 0)
Failed to create DMO filter
ERROR: Could not open required DirectShow codec wmvdmod.dll.
You need to upgrade/install the binary codecs package.
Go to http://mplayerhq.hu/homepage/dload.html
VDecoder init failed :(
Cannot find codec matching selected -vo and video format 0x33564D57.
Read DOCS/HTML/en/codecs.html!


Do you get something like this? Clear, right? Get the codecs from
mplayer.hu and put them in /usr/local/lib/win32. The README that comes
with them says they should go to /usr/local/lib/codecs, but I guess the
FC4 mplayer was compiled with win32.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]