[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

VSFTPD not working after upgrade from FC3 to FC4



I upgraded from FC3 to FC4 a couple of weeks ago. Everything seems to
be a success with the exception of VSFTPD which does not work anymore.
I have tried to solve this on and off for the past two weeks but have
had no success.

Setup description:
I have VSFTPD to be configured to use virtual users using the example
in the EXAMPLES folder in the documentation. The Berkeley database is
used to store the user name and passwords. All virtual users are mapped
to the same user and chrooted into the same directory. The setup has
worked from FC1 and survived upgrades to FC2 and FC3 without problems.

xinetd is used as a superserver.

I'll not include the conf-file here for brevity but it could be sent
upon request.

Error description:

After connecting to the box VSFTPD puts up a welcome banner and prompts
for a login.
After the password has been entered the following error message
appears:

500 OOPS: priv_sock_get_result

and it quits.

The same result both with or without the Xinetd superserver.

I have tried the following:

(1) Read somewhere that there might be a conflict if another program
tries to use the same port, but issuing a netstat -a shows no other
services using the ftp port. Tried in standalone listening mode and
shut down xinetd but that still produced the same error.

(2)I tried to switch off SELinux if that would have anything to do with
it but to no avail (using the setenforce command).

(3) I set PAM in debug mode thinking that it was the pam_userdb-module
that did not work as intended. The output looked fine, e.g.
---cut---
Jun 24 12:04:17 localhost pam_userdb[4854]: Verify user `x' with
password `vannabragare'
Jun 24 12:04:17 localhost pam_userdb[4854]: password in database is
[0x96e3bd8]`x^Y', len is 12
---cut---

(4) When setting vsftpd in "log every event mode" (or something like
that) I got the following:
---cut---
Fri Jun 24 10:06:15 2005 [pid 4877] [x] FTP response: Client
"127.0.0.1", "331 Please specify the password."
Fri Jun 24 10:06:17 2005 [pid 4877] [x] FTP command: Client
"127.0.0.1", "PASS <password>"
---cut---

No errors here either. I have no clue now.

(5) When switching to anonymous mode, VSFTPD seems to work correctly.
But why? And I don't want anonymous logins, I like the virtual user PAM
approach.

(6)-(999999)
I have fiddled with all vsftpd.conf options impatiently and to no
avail. I have also started to read the source code, but my C is very
rusty and my time limited.

Any ideas? I am getting very confused here... Since the primary use for
the machine was as an ftp server, it is somewhat worthless right now.
Is there anything changed FC3 to FC4 in PAM or anyplace else that could
have this effect?

Would be thankful for any help or ideas!

Best regards


Andreas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]