[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: VSFTPD not working after upgrade from FC3 to FC4



On Fri, 08 Jul 2005 19:35:04 -0500, Jeff Vian wrote:

>Possibly the chroot environment.  It sounds like the failure point is
>where the chroot takes affect.
>
>Anonymous by default does a chroot as well.  If you copy the default
>directory structure of the anonymous ftp users home to your virtual ftp
>users home, then try logging in again, what happens?

Both anonymous and virtual/local users map to the ftp user and
chroot():s in that users home directory. I just let it run on default.

Somehow it works with anonymous users but not with local users so I
don't think that it is the chroot environment.

Another odd thing is that I can log on as a local user and I can use
ftp as a guest user and chroot to the ftp directory!

Thus using the following PAM-file works
---cut---
auth       required     /lib/security/pam_listfile.so item=user
sense=deny file=/etc/ftpusers onerr=succeed
auth       required     /lib/security/pam_pwdb.so shadow nullok
auth       required     /lib/security/pam_shells.so
account    required     /lib/security/pam_pwdb.so
session    required     /lib/security/pam_pwdb.so
---cut---

But using the PAM-file I use for virtual users does not work
---cut---
auth required /lib/security/pam_userdb.so db=/etc/vsftpd_login
account required /lib/security/pam_userdb.so db=/etc/vsftpd_login
---cut---

To me it seems that there is a problem with pam_userdb.so and vsftpd
but I have no idea how to progress from here...

Thank you for your input!

Andreas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]