[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC3 : help, i broke my yum.



Skunk Worx wrote:

I've ended up with a yum problem on a FC3 machine and am curious if there is a way to fix it.

1) I've used rsync to create a local repository on my filesystem. This seems fine. This is in preparation for lan-based updates.

2) Earlier in the week, before the rsync, I was running out of drive space, and in a hurry, I deleted /var/cache/yum.

[snip]

5) Running "yum update" again took a little while, but it ran. However, the final line of output is :

 No Packages marked for Update/Obsoletion

...which I don't think is correct, since I can see newer packages in the rsync repo (and the /var/log/yum.log shows the last update was June 8th.)

"yum install" is working properly, just no updates.

Changing the baseurl's to http://some-net-repo yields the same result; install of a package is okay, but no update/obsoletions are detected.

Any ideas on how to correct this? Yum does not seem to be able to detect the presence of the newer packages anymore.

TIA,
SW

Have you tried

# yum check-update

?

Mike

--
p="p=%c%s%c;main(){printf(p,34,p,34);}";main(){printf(p,34,p,34);}
This message made from 100% recycled bits.
I can explain it for you, but I can't understand it for you.
I speak only for myself, and I am unanimous in that!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]