[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem compiling kernel



Im using kernel 2.6.12-1.1372_FC3. But I have tried compiling under different kernels from 2.6.9.

The hpc directory is there because the kernel is patched with openMosix support.
Ive tried an unpatched kernel too but then I just get other errors. Note that all this is working great under Debian.
Its the "make dep" part that fails. "make modules" and "make modules_install" is working fine. "make bzImage" isnt woring either.
The source is from kernel.org, yes.

I've checked the comm.o file too at the line specified but there is just a plain "}" without the quotes at that line.
Something is very fishy here. Anyways, I tried compiling the bzImage under debain and copying it to my fedora system but that doesnt work either, the system just hangs :(



Martin Carlsson wrote:


Anyway im still getting the same error even with the

make all;make modules_install;make install

command.


comm.c: In function `comm_free': comm.c:767: error: label at end of compound statement make[2]: *** [comm.o] Fel 1 make[2]: Leaving directory `/usr/src/linux-2.4.26/hpc' make[1]: *** [first_rule] Fel 2 make[1]: Leaving directory `/usr/src/linux-2.4.26/hpc' make: *** [_dir_hpc] Fel 2



What kernel source are you using? Assuming you just want to compile linux-2.4.26 why not get the source from <http://www.kernel.org/> ?

I don't recall ever seeing a top directory called "hpc"?
What does it contain?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]