[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Cannot boot from CDROM



Hi - I installed FC4 a month ago or so (from ISO's downloaded to a USB drive). Worked fine.

Today my internet connection died - a possible hardware failure.

But to be sure, I attempted to boot with a KNOPPIX CD and found I cannot boot from my CDROM.
The boot process goes directly to the FC4. I poked around trying to understand and found
(1) /boot/grub/device.map has two entries -- fd0 followed by hda (says it was generated by anaconda)
(2) /boot/grub/grub.conf lists FC4, FC4-install, and DOS (which was by the way long ago corrupted and is now useless)
(3) BIOS lists three boot devices in order CDROM, FLOPPY, and HDD-0


I have a DVD drive and a CR-RW drive internal.

I tried rearranging the BIOS order and ID's but am unsure of the relation between available choices and the drives I have.
I tried also including CDROM, using this revised file
(cdrom) /dev/hdc
(fd0) /dev/fd0
(hda) /dev/hda
and tried also with the first entry changed to (hdc) /dev/hdc


Always boots directly to FC4.

Suggestions?  Thanks much.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]