[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Compiling PHP 4.2 on FC4 Test 3



andy...

are you compiling using the source/tar files from php.net? also, what is the
./configure attribute string/params that you're using...

-bruce


-----Original Message-----
From: fedora-list-bounces redhat com
[mailto:fedora-list-bounces redhat com]On Behalf Of Andy Pieters
Sent: Thursday, June 16, 2005 11:49 AM
To: fedora-list redhat com
Subject: Compiling PHP 4.2 on FC4 Test 3


Hi All

I am trying to compile php 4.2 on Fedora Core 4 Test 3

The compilation throws this:

make[1]: Entering directory `/home/kdedev/php-4.2.0'
/bin/sh /home/kdedev/php-4.2.0/libtool --silent --mode=link gcc  -I.
-I/home/kdedev/php-4.2.0/ -I/home/kdedev/php-4.2.0/main
-I/home/kdedev/php-4.2.0 -I/usr/local/apache/include
-I/home/kdedev/php-4.2.0/Zend -I/home/kdedev/php-4.2.0/ext/mysql/libmysql
-I/home/kdedev/php-4.2.0/ext/xml/expat  -DLINUX=22 -DHAVE_SET_DUMPABLE
-DUSE_HSREGEX -I/home/kdedev/php-4.2.0/TSRM -g -O2 -prefer-pic   -o
libphp4.la -rpath /home/kdedev/php-4.2.0/libs -avoid-version   stub.lo
Zend/libZend.la sapi/apache/libsapi.la main/libmain.la
regex/libregex.la /home/kdedev/php-4.2.0/ext/ctype/libctype.la
/home/kdedev/php-4.2.0/ext/mysql/libmysql.la
/home/kdedev/php-4.2.0/ext/pcre/libpcre.la
/home/kdedev/php-4.2.0/ext/posix/libposix.la
/home/kdedev/php-4.2.0/ext/session/libsession.la
/home/kdedev/php-4.2.0/ext/standard/libstandard.la
/home/kdedev/php-4.2.0/ext/xml/libxml.la
TSRM/libtsrm.la -lpam -lcrypt -lresolv -lm -ldl -lnsl -lresolv -lcrypt -ldl
/usr/bin/ld: errno: TLS definition in /lib/libc.so.6 section .tbss
mismatches
non-TLS reference
in /home/kdedev/php-4.2.0/ext/mysql/.libs/libmysql.al(my_error.lo)
/lib/libc.so.6: could not read symbols: Bad value
collect2: ld returned 1 exit status
distcc[17817] ERROR: compile (null) on localhost failed
make[1]: *** [libphp4.la] Error 1
make[1]: Leaving directory `/home/kdedev/php-4.2.0'
make: *** [all-recursive] Error 1


Anybody know how to fix this?


Ps: I know that PHP 5 is out, but I am assigned a task to port a program to
PHP 4.2+ < 5.0


With kind regards

Andy

--
Registered Linux User Number 379093
-- --BEGIN GEEK CODE BLOCK-----
Version: 3.1
GAT/O/>E$ d-(---)>+ s:(+)>: a--(-)>? C++++$(+++) UL++++>++++$ P-(+)>++
L+++>++++$ E---(-)@ W+++>+++$ !N@ o? !K? W--(---) !O !M- V-- PS++(+++)
PE--(-) Y+ PGP++(+++) t+(++) 5-- X++ R*(+)@ !tv b-() DI(+) D+(+++) G(+)
e>++++$@ h++(*) r-->++ y--()>++++
-- ---END GEEK CODE BLOCK------
--
Check out these few php utilities that I released
 under the GPL2 and that are meant for use with a
 php cli binary:

 http://www.vlaamse-kern.com/sas/
--

--


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]