[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Cant detect Hard Drive while installing Fedora Core 3 on Dell 8400



On Wed, 2005-03-30 at 15:08 -0600, smorrison20 neb rr com wrote:
> I am having some toruble installing FC3 on my dell 8400. It tells me it hasnt deteced a Hard Drive and I will need to manually set it up. I am very new to alot of this and do not know what I am looking for to set this up. I have a sata hard drive (what ever generic brand dell gives you) and don't know where to find what I need to get FC3 to detect my hard drive. If you need more information to help answer this send me a message. Thanks for the help.
> 
> 
> Shawn Morrison
> smorrison20 neb rr com
> lionsfan208 aim
> 
> 

Shawn,

I also ran into this problem, but "solved" it by mounting a PATA
harddisk on which I installed FC3. Later I found out that I could mount
the SATA drive with the Windows NTFS partition, by manual intervention
(see mailing list archive for a posting from me (March 8, 2005) looking
for the title: "Dell Dimension 8400 and SATA: partly succeeded"). It
boils down to the fact that Kudzu (hardware detection program)
recognizes the SATA-controller and loads the wrong driver for it. By
manually unloading the driver, and loading another driver, the SATA-
drive can be mounted and read. I have put the problem with Kudzu in
Bugzilla (see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?
id=151505). I hope that they can find a solution to this problem.

Another solution is to play with the BIOS setting of the 8400. Some time
ago Jan Morales posted a message stating:
"
There is a setting in my Dell Dimension 8400 BIOS under "Drives" called
"SATA operation". The default is "RAID autodetect/AHCI". I changed it to
"Combination" (SATA/PATA combination mode) and FC3 installed without a 
hitch--I'm using it now.
"

If you want to use the 8400 with Linux only, then this is probably the
easiest way to go. If you also want to keep on using the Windows install
on the 8400, then I do have to warn you that Windows does not boot with
the adapted BIOS setting. You will have to switch the setting back and
forth to boot either OS. BTW, I don't know if grub can handle both
settings.
People have been talking about doing a repair of the Windows
installation and leaving the setting at SATA/PATA combination mode.
Others say that you should reinstall Windows with SATA/PATA combination
mode. I tried none of them, so I can not give you advice on this.
Maybe others can fill you in here...

BTW: if you google on "Dell Dimension 8400 SATA linux" then you should
find some links that give you this information (maybe a little more
extensive).

Regards,
Aad


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]