[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: selinux again, and x forwarding



Walter Petrel wrote:

I just solved one selinux problem only to find another.

The old problem: httpd wouldn't serve up userdir files after upgrading to FC 4 with selinux. Changing the httpd config and the context of the user directories didn't help. The solution, provided here, was to relabel.

The new problem: X forwarding no longer works. This machine is not tied into our system's NIS system, never has been, but X forwarding always worked before. I don't know if the problem could be there. The ssh and X configs are the default for FC 4. The machines I'm connecting to are mostly RH machines -- like v 3.x. The message I get on the terminal is about not being able to open the display.

I've tried ssh -X and ssh -Y. And ForwardX11Trusted is set, but ForwardX11 is not, both in /etc/ssh/ssh_config

One complication: prior to rebooting, I upgraded the system. This was on Monday, so it included the kernel upgrade.

Thanks.




Try setenforce 0 as root and then try the x forwarding, if it still does not work, it is probably not an SELinux problem.

Dan

--



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]