[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: I'm in YUM up2date hell



On Fri, 2005-09-02 at 13:24 -0500, bbales wrote:
> On Friday 02 September 2005 01:22, Paul Howarth wrote:
> > On Thu, 2005-09-01 at 12:58 -0500, bbales wrote:
> > > I thought yum had eliminated the old "dependency hell" we used to
> > > fight our way through.  Now I am in the new hell.
> > >
> > > I installed FC3 and it came with kernel 2.6.9-1.667.  I used it a few
> > > weeks and then ran up2date.  I was rewarded with kernel
> > > 2.6.12-1.1372_FC3, which refused to provide sound with my Intel i82801
> > > sound chip.  I can go back to the 2.6.9 kernel and sound works very
> > > well, but I can't seem to solve the sound problem with the 2.6.12
> > > kernel.
> > >
> > > Up2date shows a kernel 2.6.12-1.1376 is available, but won't install
> > > it.  I get the following messages:
> > > Test install failed because of package conflicts:
> > > The following packages were added to satisfy dependencies
> > > selinux-policy-targeted  1.17.30-3.16 is already installed
> > > (Which doesn't explain why it won't install anything else.)
> > >
> > > yum update ends up with the following:
> > > kernel conflicts with selinux-policy-targeted < 1.17.30-3.16
> > >
> > > yum install selinux-policy-targeted gives:
> > > nothing to do
> > >
> > > yum update selinux-policy-targeted gives:
> > > Could not find update match for selinux-policy-targeted
> > >
> > > Is there some way out of this?
> >
> > Please post the full output of:
> > # rpm -q kernel selinux-policy-targeted
> > # yum update
> >
> > Paul.
> 
> Thanks for answering.  bruce
> [root blacky bruce]# rpm -q kernel selinux-policy-targeted
> kernel-2.6.9-1.667
> kernel-2.6.12-1.1372_FC3
> selinux-policy-targeted-1.17.30-2.19
> selinux-policy-targeted-1.17.30-3.16
> [root blacky bruce]# yum update
> Setting up Update Process
> Setting up Repos
> base                      100% |=========================| 1.1 kB    00:00
> updates-released          100% |=========================|  951 B    00:00
> freshrpms                 100% |=========================|  951 B    00:00
> Reading repository metadata in from local files
> base      : ################################################## 2622/2622
> updates-re: ################################################## 1025/1025
> freshrpms : ################################################## 291/291
> Resolving Dependencies
> --> Populating transaction set with selected packages. Please wait.
> ---> Package kernel.i686 0:2.6.12-1.1376_FC3 set to be installed
> --> Running transaction check
> --> Processing Conflict: kernel conflicts selinux-policy-targeted < 
> 1.17.30-3.16
> --> Finished Dependency Resolution
> Error: kernel conflicts with selinux-policy-targeted < 1.17.30-3.16
> [root blacky bruce]#

You've got two selinux-policy-targeted packages installed:

selinux-policy-targeted-1.17.30-2.19
selinux-policy-targeted-1.17.30-3.16

The new kernel conflicts with the old selinux-policy-targeted package,
so you could try removing that:

# rpm -e selinux-policy-targeted-1.17.30-2.19

It's possible though that the 2.6.9-1.667 kernel won't work properly
with the later selinux-policy-targeted package.

Paul.
-- 
Paul Howarth <paul city-fan org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]