[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: No Sound with kernel upgrade



bbales wrote:

I am using FC3 and kernel 2.6.12-1.1376 and an Intel i82801 sound chip and I can't get sound working. Everything looks like it is working, but no sound.

xmms gives notice:
	Please check that your soundcard is configured properly
	You have the correct output plugin.
	No other program is blocking the sound card.
and then shows the xmms window with a very active audio band display.

How does one configure a sound card?

play <song.wav> gives
	sox: can't open output file '/dev/dsp': device or resource busy

This can't hardly be true.  This was the first thing I did after boot.

I've looked at alsamixer, aumixer and amixer to be sure none is muted.

Since sound played before I updated from the 2.6.9 kernel, and it still works with knoppix, I'm sure the hardware is OK.

kudzu and /etc/sysconfig/hwconf indicate that the hardware has been recognized and a driver (snd-intel8x0) assigned.

We no longer have sndconfig, although I don't know that it would help here.

Any suggestions would be appreciated,
bruce




I have that problem with every kernel upgrade :-(

1.) Boot into the previous kernel ( the one with the sound card working).

2.) Su to root.

3.) Copy /etc/modprobe.conf to another directory/floppy disc.

4.) Reboot with the new kernel.

5.) Su to root & copy the modprobe.conf copy you made over the top of /etc/modprobe.conf.

6.) Reboot once again using the new kernel & you should be good to go :-)

taharka

Lexington, Kentucky U.S.A.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]