[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Strange update error message and system will not update



I have 3 FC2 machines and recently did an apt-get update on them. All seemed 
to go well. Today I tried to do another update and I now get the following 
update message on all three machines. One is a Dell server, and the other two 
are workstations.

rpmdb: Program version 4.3 doesn't match environment version
error: db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH: Database 
environment version mismatch
error: cannot open Packages index using db3 -  (-30974)
error: cannot open Packages database in /var/lib/rpm
E: could not open RPM database

This looks really bad. Is it as bad as it looks and is there a way to recover 
from this without having to reinstall the whole system?

Charles Layno
Greensboro, NC


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]