[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum + up2date on FC4 x86_64 not working as well as hoped.



Hi all,

Dependency problems here I'm hoping somebody can help with..

# yum install gcc
Repository base already added, not adding again
Repository base already added, not adding again
Setting up Install Process
Setting up repositories
base                      100% |=========================|  951 B
00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for gcc to pack into transaction set.
gcc-4.0.1-4.fc4.x86_64.rp 100% |=========================|  30 kB
00:00
---> Package gcc.x86_64 0:4.0.1-4.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc
--> Processing Dependency: cpp = 4.0.1-4.fc4 for package: gcc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for cpp to pack into transaction set.
cpp-4.0.1-4.fc4.x86_64.rp 100% |=========================|  22 kB
00:00
---> Package cpp.x86_64 0:4.0.1-4.fc4 set to be updated
---> Downloading header for glibc-devel to pack into transaction set.
glibc-devel-2.3.5-10.3.x8 100% |=========================|  87 kB
00:00
---> Package glibc-devel.x86_64 0:2.3.5-10.3 set to be updated
--> Running transaction check
--> Processing Dependency: glibc-headers for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.3.5-10.3 for package:
glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for glibc-headers to pack into transaction set.
glibc-headers-2.3.5-10.3. 100% |=========================| 121 kB
00:00
---> Package glibc-headers.x86_64 0:2.3.5-10.3 set to be updated
--> Running transaction check
--> Processing Dependency: kernel-headers >= 2.2.1 for package:
glibc-headers
--> Processing Dependency: kernel-headers for package: glibc-headers
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-headers >= 2.2.1 is needed by package
glibc-headers
Error: Missing Dependency: kernel-headers is needed by package
glibc-headers


And with up2date :

# up2date -i gcc

Fetching Obsoletes list for channel: fedora-patches-stable...

Fetching Obsoletes list for channel: fedora-core...

Fetching Obsoletes list for channel: vcapps...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
gcc                                     4.0.1          4.fc4
x86_64


Testing package set / solving RPM inter-dependencies...
Repository base already added, not adding again
Repository base already added, not adding again
Baseurl(s) for repo: ['http://kickstart/fedora/updates/4/x86_64/']
Setting up Package Sacks
Excluding Incompatible Archs
Finished
An error has occurred:
exceptions.TypeError
See /var/log/up2date for more information

Up2date log says :

[Wed Sep  7 17:01:16 2005] up2date   File "/usr/sbin/up2date", line
1265, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 800, in main
    fullUpdate, dryRun=options.dry_run))
   File "/usr/sbin/up2date", line 1137, in batchRun
    batch.run()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 78, in run
    self.__dryRun()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 163, in
__dryRun
    self.percentCallback)
   File "/usr/share/rhn/up2date_client/up2date.py", line 386, in dryRun
    ret = depsolve.solvedep()
   File "/usr/share/rhn/up2date_client/depSolver.py", line 722, in
solvedep
    ret = self.process_deps(deps)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 616, in
process_deps
    changed = self.__dependencies(dependencies)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 383, in
__dependencies
    added = self.__add(solved, check = 1)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 221, in __add
    hdr = headerList[p]
   File "/usr/share/rhn/up2date_client/headers.py", line 37, in
__getitem__
    self.__retrievePackage(item)
   File "/usr/share/rhn/up2date_client/headers.py", line 42, in
__retrievePackage
    hdr, sourceType = rpcServer.doCall(self.repos.getHeader, item)
   File "/usr/share/rhn/up2date_client/rpcServer.py", line 316, in
doCall
    ret = apply(method, args, kwargs)
   File "/usr/share/rhn/up2date_client/repoDirector.py", line 32, in
getHeader
    return self.handlers[channel['type']].getHeader(pkg, msgCallback,
progressCallback)


And another problem with httpd :

# yum install httpd
Repository base already added, not adding again
Repository base already added, not adding again
Setting up Install Process
Setting up repositories
base                      100% |=========================|  951 B
00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for httpd to pack into transaction set.
httpd-2.0.54-10.1.x86_64. 100% |=========================|  62 kB
00:00
---> Package httpd.x86_64 0:2.0.54-10.1 set to be updated
--> Running transaction check
--> Processing Dependency: libapr-0.so.0()(64bit) for package: httpd
--> Processing Dependency: libaprutil-0.so.0()(64bit) for package: httpd
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for apr to pack into transaction set.
apr-0.9.6-3.1.x86_64.rpm  100% |=========================| 7.6 kB
00:00
---> Package apr.x86_64 0:0.9.6-3.1 set to be updated
--> Running transaction check
--> Processing Dependency: libaprutil-0.so.0()(64bit) for package: httpd
--> Finished Dependency Resolution
Error: Missing Dependency: libaprutil-0.so.0()(64bit) is needed by
package httpd



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]