[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum + up2date on FC4 x86_64 not working as well as hoped.



Yes, I noticed that foolishness not long after sending the email :

# yum install gcc
Repository base already added, not adding again
Repository base already added, not adding again
Setting up Install Process
Setting up repositories
base                      100% |=========================|  951 B
00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gcc.x86_64 0:4.0.1-4.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc
--> Processing Dependency: cpp = 4.0.1-4.fc4 for package: gcc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package cpp.x86_64 0:4.0.1-4.fc4 set to be updated
---> Package glibc-devel.x86_64 0:2.3.5-10.3 set to be updated
--> Running transaction check
--> Processing Dependency: glibc-headers for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.3.5-10.3 for package:
glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-headers.x86_64 0:2.3.5-10.3 set to be updated
--> Running transaction check
--> Processing Dependency: kernel-headers >= 2.2.1 for package:
glibc-headers
--> Processing Dependency: kernel-headers for package: glibc-headers
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-headers >= 2.2.1 is needed by package
glibc-headers
Error: Missing Dependency: kernel-headers is needed by package
glibc-headers

Where does the requirement for kernel-headers come from, it's not
installed on my other boxes running gcc but seems to come from
glibc-headers  :

# rpm -qRp glibc-headers-2.3.5-10.3.x86_64.rpm
/bin/sh
glibc = 2.3.5-10.3
kernel-headers
kernel-headers >= 2.2.1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1


i386 FC4 box :

# rpm -q gcc
gcc-4.0.1-4.fc4

# rpm -qR glibc-headers
/bin/sh
glibc = 2.3.5-10.3
kernel-headers
kernel-headers >= 2.2.1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

# rpm -q kernel-headers
package kernel-headers is not installed

Ok, how does that work :)

On Wed, 2005-09-07 at 09:54 +0100, Paul Howarth wrote:
> Naoki wrote:
> > Dependency problems here I'm hoping somebody can help with..
> > 
> > # yum install gcc
> > Repository base already added, not adding again
> > Repository base already added, not adding again
> 
> Step 1 is to clean up your yum configuration. In FC4 there should be no 
> repo definitions in /etc/yum.conf - they should be in .repo files in the 
> /etc/yum.repos.d directory; you've got two or maybe even three 
> definitions for the [base] repo, which isn't helping. So clean out 
> yum.conf and rationalise the entries in /etc/yum.repos.d so that you 
> know which repos you've enabled and there is only one definition of each 
> one.
> 
> Then try again and we'll take it from there.
> 
> Paul.
> 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]