[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: sharing printer with samba in FC4 (update)



Deepak Shrestha wrote:

Thanks for the some detailed advice. I will give it a
try. Right now now I am trying to install the new rpm
package with upgrade version but it doesn't like. I
want to uninstall all previous installed pacakages but
my rpm query only shows the samba packages. If I try
to upgrade the samba-common package, it shows the
error that current version of samba-common is needed
by the currently running samba. Can you give some
steps on how did you upgraded to new version of samba?

Do I need to stop the samba server first? or rpm
package know how to do it itself?

Why can't I just upgrade the rpms? rpm -Uvh doesn't
work.

Do I need wipe out the current samba entirely before I
will install the new package?

Thanks a lot!


I ran into the same problem when I first tried to upgrade. First you will need to uninstall the old samba. When I did that though, it complained of dependency from samba-config-samba. I looked at samba-config-samba and decided that I didn't really need the gui so I uninstalled that too. After it was uninstalled, you can then go ahead and uninstall fedora's samba.


Before I installed samba 3.0.20 though, I had to install samba-common (from samba's site, of course) first. Once that's done, you can installed samba 3.0.20.

You can stop samba first to be safe but I think rpm will do that for you.

Hope that helps.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]