[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ipw2200 wireless not working on Compaq Presario V2413AP







>> Hi guys,
>>
>> I tried getting my wireless internet running on my Presario laptop but
>> after installing the ipw2200 firmware from freshrpms I still couldn't
>> get it working correctly. From the network device setting the Intel Pro
>> Wireless was recognised but it just wouldn't initialise, complaining
>> that the device might not be present. From dmesg message though, there
>> is an error related to ipw2200 couldn't get the IRQ setting assigned,
>> details attached below. What do I need to do to get it fixed? Thanks for
>> any help provided.

> That will teach you to buy a compaq :-D
>
> Anyway - it looks like you got some acpi issues. Try booting without > acpi and see what happens... also make sure you update to the latest > bios - Compaq is notorious for the errors in their bioses...
>
> Peter.


Thanks Peter, I tried using acpi=off and it worked. Sound is working now and usb wireless mouse is too, so this is definitely an acpi issue. But is this that serious though? I mean, all I can read with my little knowledge from dmesg is that those features were recognised, it is just IRQ allocating problem. However, I would really like to be able to use acpi though for monitoring the battery status and also adjusting cpu frequency. Is there anyway to fix this? Will modifying the DSDT help in this case? Also, is Fedora 4's kernel allow the implementation of custom DSDT already or kernel recompilation is still needed for this purpose?

As for BIOS, this is the latest BIOS that I could find available, so little can I do at that department.

Well, as far as Compaq is concerned, that is surely a lesson for me BUT I thought that Compaq is part of HP and that HP supports linux so there you go. Checking from linux on laptops website, there is none that says dont buy compaq presario v2000 series, in fact some show that v2000 series work with some other distros but there is no example with Fedora though. If I am stuck after all possible attempts with Fedora then I will try with other distros. Please bear with me for a few more shots at this problem.

Alimin




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]