[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problem on apache or php using 2 or more includes on php



Hi all,


When i try to include 2 or more scripts on php in a shtml page the
error_log gives the following line:

[Sat Sep 10 14:10:15 2005] [notice] child pid 16436 exit signal
Segmentation fault (11)

I mean... i have the following pages:

test1.php
---------
<?
   echo "<p>php_test1.php: OK</p>";
?>
---------


test2.php
---------
<?
   echo "<p>php_test1.php: OK</p>";
?>
---------

test1.html
----------
<p>html_test1.html: OK</p>


test2.html
----------
<p>html_test2.html: OK</p>


test_html.shtml
---------------
<!--#include virtual="html_test1.html"-->
<p>
<!--#include virtual="html_test2.html"-->



test_php.shtml
--------------
<!--#include virtual="html_test1.html"-->
<p>
<!--#include virtual="html_test2.html"-->


When i call test_html.shtml the page works ok, but when i try to load
test_php.shtml the prev error is logged and nothing is showing in the
page.


This only happens whith: httpd-2.0.54-10.2 php-5.0.4-10.4 (FC4), because
if i downgrade to httpd-2.0.54-10 php-5.0.4-10.4 in the same machine
every thing works ok.,


googling a found a similar problem a year ago
(http://bugs.php.net/bug.php?id=17868), but apache blames php, and php
blames apache... 

Anybody have the same problem or knows how to fix-it?.


10x !!

--
Omar Martinez
Colnodo
http://www.colnodo.apc.org



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]