[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OT: FireFox shows source instead of running ..



Jamie Bohr wrote:
I have having a weird FireFox problem. In stead of FireFox parcing the code I see the source code (right click on any web page and see "View Page Source"). A good example of this would be http://webclient2.omnipod.com/. Any ideas?

Hi Jamie,

Here's a follow up on the omnipod site.

Telnet to webclient2.omnipod.com 80
GET / HTTP/1.1
HOST: webclient2.omnipod.com

You will receive the following headers followed by the requested document. Here are the supplied headers.

HTTP/1.1 200 OK
Date: Wed, 14 Sep 2005 20:27:39 GMT
Server: Apache
Last-Modified: Tue, 30 Aug 2005 15:33:48 GMT
ETag: "195e3-18eb-43147c5c"
Accept-Ranges: bytes
Content-Length: 6379
Content-Type: text/plain

Now, look at the last header. It is not text/html, it is text/plain. That is an express instruction to your browser to display the document as received *without* any parsing. (Actually, I'd bet the browser wraps the document in a <pre></pre> tag set so that the browser's style settings are applied to its display.)

Firefox is doing exactly as requested. omnipod's webserver is misconfigured. To wit, its index.html is delivered with a text/html header, its index.shtml is not. The Apache webserver has directives that control that, they're just not set (correctly).

Hope that explains that in enough detail.

(Hey, Omnipod!!!)

:m)

PS.  didn't find any problem with spamcom.net

Thanks,
   Jamie Bohr



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]