[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Yum install getting GPG error



I am trying to install the ImageMacick package on FC4. This box was initially installed back in June as a test and is now being brought into active service.

Here is the command:
     yum install ImageMagick

This is the output I am seeing (the failure is at the end):
------
Setting up Install Process
Setting up repositories
livna                     100% |=========================|  951 B    00:00
updates-released          100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 742 kB    00:01
extras    : ################################################## 2100/2100
Added 23 new packages, deleted 0 old in 1.78 seconds
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package ImageMagick.i386 0:6.2.2.0-3.fc4.0 set to be updated
--> Running transaction check
--> Processing Dependency: libgs.so.7 for package: ImageMagick
--> Processing Dependency: libwmflite-0.2.so.7 for package: ImageMagick
--> Processing Dependency: libltdl.so.3 for package: ImageMagick
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libwmf.i386 0:0.2.8.3-8 set to be updated
---> Package ghostscript.i386 0:7.07-40 set to be updated
---> Package libtool-ltdl.i386 0:1.5.16.multilib2-2 set to be updated
--> Running transaction check
--> Processing Dependency: urw-fonts >= 1.1 for package: ghostscript
--> Processing Dependency: ghostscript-fonts for package: ghostscript
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package urw-fonts.noarch 0:2.3-1 set to be updated
---> Package ghostscript-fonts.noarch 0:5.50-13 set to be updated
--> Running transaction check
--> Processing Dependency: chkfontpath for package: urw-fonts
--> Processing Dependency: /usr/X11R6/bin/mkfontscale for package: urw-fonts
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package chkfontpath.i386 0:1.10.0-4 set to be updated
---> Package xorg-x11-font-utils.i386 0:6.8.2-37.FC4.45 set to be updated
--> Running transaction check
--> Processing Dependency: xfs for package: chkfontpath
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xorg-x11-xfs.i386 0:6.8.2-37.FC4.45 set to be updated
--> Running transaction check
--> Processing Dependency: /usr/bin/ttmkfdir for package: xorg-x11-xfs
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package ttmkfdir.i386 0:3.0.9-16.1 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
ImageMagick i386 6.2.2.0-3.fc4.0 updates-released 2.7 M
Installing for dependencies:
chkfontpath i386 1.10.0-4 base 13 k ghostscript i386 7.07-40 base 7.6 M ghostscript-fonts noarch 5.50-13 base 808 k libtool-ltdl i386 1.5.16.multilib2-2 updates-released 25 k libwmf i386 0.2.8.3-8 base 804 k ttmkfdir i386 3.0.9-16.1 updates-released 49 k urw-fonts noarch 2.3-1 base 4.5 M xorg-x11-font-utils i386 6.8.2-37.FC4.45 updates-released 123 k xorg-x11-xfs i386 6.8.2-37.FC4.45 updates-released 138 k

Transaction Summary
=============================================================================
Install     10 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 17 M
Is this ok [y/N]: y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID db42a60e
Public key for ghostscript-fonts-5.50-13.noarch.rpm is not installed
Retrieving GPG key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
GPG key at file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora (0x4F2A6FD2) is already installed


The GPG keys listed for the "Fedora Core 4 - i386 - Base" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.
------

As far as I can tell it is saying that the ghostscript-fonts package is not properly signed on the repository. I am not certain how to proceed.

--
Bryan White, ArcaMax Publishing Inc.

I never look back, darling. it distracts from the now. - Edna Mode


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]