[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC4 error?



> Hongwei Li wrote:
>> Hi,
>>
>> I just deleted all old partitions, created new partitions and installed a
>> fresh FC4 system.  The installation did not show any error.  After the
>> installation, I reboot it.  During the booting process, I saw an error
>> message
>> after "Setting hostname xxx: [OK]" as:
>>
>> Setting up Logical Volume Management: /var/lock mkdir failed, read-only
>> filesystem
>>
>> Then, other booting processes pass through. Now, the system is running, I
>> can
>> access it using ssh, httpd is working.  However, when I start dovecot (I did
>> not change /etc/dovecot.conf), it failed:
>>
>> # /etc/init.d/dovecot start
>> Starting Dovecot Imap:                                     [FAILED]
>>
>> I turn the service dovecot on, then reboot.  I saw the error message as
>> above
>> and the new error:
>>
>> Starting service dovecot failed: can't use SSL certificate ...
>> /etc/pki/dovecot/dovecot.pem permission denied
>>
>> (it went through so fast that I can't catch all the words).  If I start
>> dovecot manually, it is ok:
>>
>> # /usr/sbin/dovecot
>> # ps xa | grep dov
>>  2622 ?        Ss     0:00 /usr/sbin/dovecot
>>  2624 ?        S      0:00 dovecot-auth
>>
>> The system logs don't show anything related to dovecot, nor the message
>> ".../var/lock mkdir failed..."
>>
>> I update the kernel from 2.6.11-1.1369_FC4 to 2.6.12-1.1447_FC4, reboot, but
>> got the same error messages as before.
>>
>> Can somebody tell me what's wrong with the installation and the system?  Are
>> the above two error messages related each other?  Will the error "/var/lock
>> mkdir failed" cause any other problems?
>>
>> If I turn off selinux, then I can start service dovecot:
>>
>> # setenforce 0
>> # /etc/init.d/dovecot start
>> Starting Dovecot Imap:                                     [  OK  ]
>>
>> and it creates an entry /var/lock/subsys/dovecot.  However, when I reboot
>> the
>> system, the same problems and errors show up again.  It seems that it is
>> related to selinux.  I am using targeted, enforcing selinux and has the
>> policy
>> selinux-policy-targeted-1.23.16-6 installed from the FC4 CDs.
>>
>> How to solve the problem?  Thanks a LOT!
>
> The latest selinux-policy-targeted errata package contains some dovecot
> fixes. Try updating that and see if things improve.
>
> Paul.
>

I updated selinux-policy-targeted from 1.23.16-6 to 1.25.4-10.1, then service
dovecot can start without error.  However, booting process still shows error:

 Setting up Logical Volume Management: /var/lock mkdir failed, read-only
 filesystem

Setting selinux default as permissive, then reboot, still get the same error. 
So, this one is not selinux issue. Then, what does it actually mean?  How to
fix it?  BTW, I reinstalled FC4 twice, the same situation.

Thanks for any help!

Hongwei


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]