[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: xorg-x11 update may have broken my system



Francois Massonneau wrote:

Hello,

This morning, yum updated automatically my system, and I saw it updated the Xorg-X11 packages. I shut down my computer without any pb, and this afternoon, I 've tried to start my linux box, and it doesn't want ;-(

It can boot using the FC4 install DVD rom, in rescue mode, but I can't make it to work using the usual boot process.

Grub comes fine, it begins to boot, the partitions are mounted, but when it wants to display the little windows (now the boot process is graphical) that shows the boot process, I have a fully colored screen, and nothing happen. I have to power it off to shut it down.

As only the xorg-x11 packages were updated, I suppose, this comes from them.

Now I would like to be able to downgrade them, but I don't know how.

I can boot from the install dvd, and boot in rescue mode, then chroot /mnt/sysimage, but once there, what can I do ? I have another computer where I can burn a dvd with the previous xorg-x11 packages, but I don't know how to mount that dvd when I'm in rescue mode. A "dmesg | grep hd" shows me that my dvd burner is "hdc", but when I type : mount -t ext3 /dev/hdc /media/cdrecorder, I have always the same message : "/dev/hdc doesn't exist", or something similar.

Thank you for your help
Francois

It seems it would be easier to press any key to display the grub menu, then press a to edit your selected boot entry. Remove the entry which references rhgb quiet and enter a space followed by the number 3 to allow you to boot into level 3. In level 3, enter your user name and password. Try typing startx at the command prompt. (regular user). If you still have a problem with X starting, backtracking X is probably needed. If X still shows problems, then ctl-alt-backspace to kill X. This will let you know if X is broken when loaded in runlevel 5 and also in runlevel 3. There are differences between the way X is launched from each level, though I do not know the specifics. Now, open a root terminal on another tty and supply the root username and password. Put your DVD in the drive and then mount the dvd from commandline. Usually something like mount /media/cdrecorder works. Your system might be different.
change to the directory where you have the rpms on the DVD.
run rpm -Uvh xorg-x11*.<arch>.rpm --oldpackage within the directory that contains the xorg rpms. Xorg should be rollde back to the later version. Ideally rpm -Fvh xorg-x11*.<arch>.rpm --oldpackage would be ideal, but did not work the last time that I tried it out.

Before you get too far back with backtracking xorg-x11, it would be helpful to know what type of video card you are using and if you are using stock or third party drivers for X. This version of X was released for security reasons and it would be wise to be able to use a more protected version of X.

Good luck,
Jim

--
QOTD:
	If it's too loud, you're too old.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]