[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora Core 4 on Dell Inspiron 6000



I just installed FC4 on a new Dell Inspiron 6000 and I want to record
my discoveries to help others.

You should start by looking at http://tuxmobil.org/dell.html

I selected this machine because:

- Intel seems to make the specs available for their graphics chips so
  decent open source support is possible.  Unlike ATI and nVidia.

- Intel seems to make 802.11g wireless drivers available.  Unlike
  Broadcom and most of the others.

- Pentium M seems to be the best low-power mainstream CPU

- Dell made a really nice high-res LCD available at a reasonable price


The hard drive, as delivered has a big WinXP/NTFS partition and a
small hidden maintenance partition.  I did not want to run WinXP even
once since I'd have to agree to an odious license.  But I didn't want
to wipe out the partitions either -- the notebook is for someone else.

I booted Knoppix, used ntfsresize and fdisk to shrink the NTFS
partition.  Note: I had to use the text console since X doesn't work
on this display.  I left a big unallocated space for FC4 to play with
(i.e. add partitions within).

I tried to install FC4 and discovered all was not as easy as I'd
hoped.

The installation could not run the display under X.  So I did a text
install.  Unfortunately, the text install does not seem to allow
fine-grained control over package selection.  Oh well.

Once installed, X still did not work.  As before, the screen showed a
white hazy non-image.  I switched to a text console and edited
/etc/inittab to set the initial runlevel to 3 (text console, not X).

Instead of a blow-by-blow account, I'll try to summarize the approach
that worked for me.

The 915GM video controller is not supported by FC4's xorg X.  So:

- Use text-based install.
  Unfortunately, the text install does not seem to allow
  fine-grained control over package selection.

- Once you have installed, you will be asked to do the first reboot.
  The system will come up with an unreadable display.  It is asking
  you a bunch of first-boot questions, but there is no way to answer.
  I rebooted again and then switched to the text console
  (Control-Alt-F1).

  Change the /etc/inittab entry specifying the initial runlevel from
  5 (graphical login) to 3 (plain text logging).  No point in running
  X when it does not work.

  Some initial-but setup gets done, even in text mode, but I don't
  remember the details.

  We will fix X to work on the display, but that must come later.

- install all FC4 updates.  This probably requires networking to work.
  See later if you must use wireless; then come back here.

- Getting X working.

  Have a look at the "Display" section of.
    http://www.stud.ntnu.no/~gronslet/blog/linux-on-a-dell-x1-aka-samsung-q30/
  This is about a different Dell notebook, but the X stuff worked for
  me.

  + I needed to use the 915resolution program Martin describes.  This
    allowed me to overwrite a VESA setting to add support for the
    1920x1200 resolution of this notebook.  This setting resides in
    the RAM copy of the video BIOS.  Yuck!

    You need to make sure 915resolution is run each time the machine
    is rebooted.  I put the command, with correct arguments, in
    /etc/rc.d/rc.local . I used a full path to refer to the program
    since I'm not sure what $PATH is set to when this script is run.

  + I needed to download the files from
      http://dri.freedesktop.org/snapshots/
    that Martin mentioned.  And install them.

    This is not too nice: it overwrites some modules in the installed
    kernel.  This probably means that whenever a kernel is updated you
    need to re-install this snapshot.  Possibly whenever xorg is
    updated too -- I don't know (I haven't checked exactly what files
    are changed).

  + I don't know exactly how I got the /etc/X11/xorg.conf set up
    correctly.  To much thrashing.  Perhaps system-config-display
    would work at this point.  Consider looking at Martin's xorg.conf.

  + you can try X by issuing the "startx" command to a non-superuser
    shell prompt.  Worked for me!


Getting the IPW2200 802.11g controller working.

  The driver is in FC4.  But the (binary, non-open-source) firmware is
  not.  This must be documented in the release notes or
  somewhere like that, but I didn't see it.

  rpm.livna.org, that source of Fedora RPMs that have licensing
  issues, has an RPM for the firmware.  To get livna introduced to
  your yum, see http://rpm.livna.org/configuration.html

  Here's the rpm for the firmware:
    http://rpm.livna.org/fedora/4/i386/RPMS.lvn/ipw2200-firmware-2.2-0.lvn.2.4.noarch.rpm

  Once you've installed this, the simplest-to-explain way to get the
  driver and firmware properly loaded is to reboot.

  The network setup utility should then work.

I have not tried to figure out suspension and other ACPI issues.

I hope that this helps.

Hugh Redelmeier
hugh mimosa com  voice: +1 416 482-8253


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]