[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Grub doesn't install



Ian wrote:

Hi All,
I'm not a Linux guru but I would like to use Linux as an alternative to Windoze wherever possible. To that end I've tried installing a few different distros, the latest being FC4, but I appear to have screwed something up with grub. Sorry, but it's a long story so please bear with me. I had Mandrake 10.0 Official installed on the second hard drive in my PC (XP is on the primary drive) which used lilo (could never get grub to work) as it's bootloader, and all was fine. Then I tried FC4, which installed grub and again everything seemed to work okay, but I couldn't get FC4 to recognise my Windoze drive. Tried mounting the drive as ntfs but it told me ntfs was not a valid file type.

Fedora does not come with ntfs modules. you have to install the modules from a source which provides rpms for your distro and kernel version/type. If you are talking about an entry in grub to boot windows, it ought to be visible if you press any key when grub starts loading. you should be able to arrow up or down to your preferred OS to load.

A bit of RTFMing told me that the valid file types had to live in a specific file (the name of which I've forgotten now, but you probably know it). ntfs wasn't in there so I added it. Now the mount command told me /hda had an invalid or unrecognisable header. At that point I gave up.

There seems to be some modules for FC4 at this website. Grab the one for your kernel/type and install it using the rpm program.

http://linux-ntfs.sourceforge.net/rpm/fedora4.html


Finally found my way to this forum, and found the post about booting with "linux rescue", chroot /mnt/sysimage and grub-install /dev/hda. Tried that and got a message saying /dev/hdb1 (where FC4 is installed) did not have a valid BIOS file (sorry, again I don't remember exactly what the message said, but it was something along those lines. It definitely mentioned /dev/hdb1 and BIOS). Now I'm really stuck.

there should be a file in your /boot/grub directory called device.map, my file contains the below. There is some grub command which will reset this file. I however never had to do this. It tells grub where your devices are mapped to. What does your file read? (/boot/grub/device.map)
cat device.map
# this device map was generated by anaconda
(fd0)     /dev/fd0
(hd0)     /dev/hda

During FC4 install I created 3 partitions on my drive, one for /boot, one for swap and the rest for /. I formatted all partitions prior to each install.

This sounds acceptable as a layout.

My PC has an AMD2200+, 512Mb, primary drive is 40Gb (Win) and slave is 10Gb (Linux).
All help very gratefully received!

Good luck with your adventure through Linux distros.
Jim

Ian



--
QOTD:
	If it's too loud, you're too old.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]