[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC4: Hard link count is wrong?

Hongwei Li wrote:
I installed a single, fresh fc4 system, kernel 2.6.12-1.1447_FC4.  When I run
find command, I got a warning such as:

# find / -name sendmail -print
find: WARNING: Hard link count is wrong for /proc: this may be a bug in your
filesystem driver.  Automatically turning on find's -noleaf option.  Earlier
results may have failed to include directories that should have been searched.

What does this warning mean? Any bug in my filesystem? How to find the bug? If I run:

# find / -noleaf -name sendmail -print

then, no warning with the same outputs of other things.  The man page of find
shows the same text as in fc3, but I never got such warning in my several fc3
systems.  So, what is the change from fc3 to fc4 in the command find?  Why do
we need this change (I never have any problem in fc3 with command find)? Should I always use -noleaf option with find in fc4? or, in wchich cases the
option -noleaf should be used and in which cases -noleaf should not be used?

Well-known issue with FC4 kernels.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]