[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Grub doesn't install



On Tue, Sep 20, 2005 at 06:59:02AM -0400, Jim Cornette wrote:
> Ian wrote:
> 
> >Hi Jim,
> >Thanks for the response.
> >My problem is, though, that I can't boot FC4 at all, because grub 
> >didn't get installed when I reinstalled FC4. The master boot record 
> >still contains lilo from my install of Mandrake, and it won't boot 
> >FC4. So I have no way of changing any grub settings. I think they call 
> >it stuck between a rock and a hard place...
> >Ian
> 
> 
> An easy way to wipe out the MBR information is by booting up a startup 
> disk for the w9x series OS and typing "fdisk /MBR". This wipes out grub 
> or lilo from the master boot record. A DOS boot disk with fdisk on it 
> should do the same, using "fdisk /mbr"
> XP uses the recovery console and I believe you type fixmbr to clear the mbr.
> To clear the MBR in Linux, I don't know how to do this. There is 
> probably a utility to clear the MBR somewhere.
> 
> Jim
Another way to do it is:
dd if=/dev/zero of=/dev/hda bs=1 bc=446 
or:
dd if=/dev/zero of=/dev/hda bs=446  bc=1

But I don't understand why you can't boot with linux rescue, chroot to
your FC4  root partition (chroot /mnt/sysimage) and run grub-install

Obviously hda might be hdb or sda, etc.
-- 

-------------------------------------------
Aaron Konstam
Computer Science
Trinity University
telephone: (210)-999-7484


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]