[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC4: Hard link count is wrong?



Hongwei Li wrote:

I installed a single, fresh fc4 system, kernel 2.6.12-1.1447_FC4.  When I run
find command, I got a warning such as:

# find / -name sendmail -print
/etc/log.d/scripts/services/sendmail
/etc/rc.d/init.d/sendmail
/etc/sysconfig/sendmail
find: WARNING: Hard link count is wrong for /proc: this may be a bug in your
filesystem driver.  Automatically turning on find's -noleaf option.  Earlier
results may have failed to include directories that should have been searched.
/usr/lib/sendmail
/usr/sbin/sendmail
/var/lock/subsys/sendmail

What does this warning mean?  Any bug in my filesystem?  How to find the bug?
If I run:

# find / -noleaf -name sendmail -print

then, no warning with the same outputs of other things.  The man page of find
shows the same text as in fc3, but I never got such warning in my several fc3
systems.  So, what is the change from fc3 to fc4 in the command find?  Why do
we need this change (I never have any problem in fc3 with command find)?
Should I always use -noleaf option with find in fc4? or, in wchich cases the
option -noleaf should be used and in which cases -noleaf should not be used?

Quoting shamelessly from the kernel documentation:

    The /proc file system (procfs) is a special file system in the
    linux kernel. It's a virtual file system: it is not associated
    with a block device but exists only in memory. The files in the
    procfs are there to allow userland programs access to certain
    information from the kernel (like process information in
    /proc/[0-9]+/), but also for debug purposes (like /proc/ksyms).

The link count error is a kernel bug.  It is not a problem in any file
system on your disk.  It is not due to any change in the 'find' command.

Looks like the fix in the current kernel doesn't work.  You can add a
comment to either of these bug reports:

    https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160253
    https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=162418

--
Bob Nichols         Yes, "NOSPAM" is really part of my email address.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]