[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC4 cvs pserver login issue



All,

I have set up the cvs pserver on FC4 following the proper procedure.
However when I try to run the cvs login, I got the following problem.

----------------
$ cvs -d :pserver:echan torpedo corp cmates com:/mycvsroot login
Logging in to :pserver:echan torpedo corp cmates com:2401/mycvsroot
CVS password:
cvs [login aborted]: unrecognized auth response from
torpedo.corp.cmates.com: cv
s pserver: cannot open /mycvsroot/CVSROOT/config: Permission denied
-----------------

I searched the web and it seems that some people have the similar issue.
But I couldn't find a solution to resolve my problem. Can someone help?

I don't think the cvs pserver set up issue. I can telnet to the 2401
port and got the response. 

------------------
$ telnet torpedo.corp.cmates.com 2401
Trying 172.20.44.83...
Connected to torpedo.corp.cmates.com.
Escape character is '^]'.
foo
cvs [pserver aborted]: bad auth protocol start: foo
Connection closed by foreign host.
------------------

The files under /mycvsroot/CVSROOT/ can be accessible by anyone. I don't
know why it complained about the permission issue.

------------------
I even did a strace and got the similar result...
3957  mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0)
= 0xb7fb6000
3957  read(0, "BEGIN VERIFICATION REQUEST\n/mycv"..., 1024) = 79
3957  open("/mycvsroot/CVSROOT/config", O_RDONLY) = -1 EACCES
(Permission denied
)
-----------------

Any help is appreciated...

Thanks,
EDDIE








[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]