[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mounting floppy in read/write mode by user



--- Jeff Vian <jvian10 charter net> wrote:

> How did you mount it?  There are 2 forms of the
> command.  One uses the
> fstab entry and works as a user and one does not.  
> 
> If you use the form "mount <mountpoint>" the mount
> command looks at the
> entry in fstab and a standard user on the console
> should be able to
> mount it.  I use "mount /media/floppy" and it works.
> 
> If instead you use the long form "mount <device>
> <mountpoint>" it also
> requires the "-t" option to specify the filesystem
> type "mount -t
> <filesystem> <device> <mountpoint>". Using this form
> as a normal user
> without the "-t" gives the error you see.  With the
> "-t" it will tell
> you that only root can mount (unless you are already
> root).  Note that
> as root you often do not need the -t, this seems to
> be part of the
> security features built into the mount command for
> verifying privileges
> for a user.
> 

I tried mount /media/floppy (as user) but it ends up
with the same error reported by KDE.

# mount -t vfat /dev/floppy /media/floppy works fine
but only root has access to it. 
That means everytime I need to read/write in floppy i
have to use suid. This is very inconvenient.


> > > Try editing /etc/fstab (as root) to have ",user"
> after
> > > ",managed"
> > > 
> > > Mike
> > Boy am I confused. I hope some one can straighten
> this out:
> > 1. the user option allows users to mount. See man
> fstab for that
> > information.
> Yes, both "user" and "users" do that (with
> differences in the effects),
> but apparently so does the pamconsole option.  I
> tested it with/without
> that option and sure enough, when the option is not
> on the line it only
> allows root to mount the device.  When the option is
> on the line the
> user on the console can mount it.
> 
> > 2. Since the /dev/fd0 is managed, which means that
> it is managed by
> > fstab-sync and option you add like user to the
> fstab file will
> > disappear the next time you reboot. You need to
> have user added
> > through entries in the fstab-sync i(or hal)
> related files.
> If you want to make changes on the line and make it
> stick, one way is to
> remove the "managed" option on the line.  That stops
> udev/HAL/fstab-sync
> from rewriting the fstab line for that device. 
> 
> > 2. Now the clincher. My fstab entry looks just
> like the one above and
> > I can mount /media/floppy as a normal user. So my
> confusion.
> > 
> Mine looks exactly the same and I can also
> mount/unmount both floppies
> and CDROMs on my system.
> 
> > Or I am all wet and someone will correct me.
> > -- 

now  my fstabs looks like this:
----------------------------------------------
/dev/fd0  /media/floppy  auto
pamconsole,exec,noauto,user 0 0
----------------------------------------------

after reboot fstab is not overwritten.

tried 
$ mount /media/floppy

ends up with the same error as previous

# mount -t vfat /dev/floppy /media/floppy works fine
as usual

I don't know what's going on.

Deepak K. Shrestha

Send instant messages to your online friends http://uk.messenger.yahoo.com 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]