[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Grub doesn't install



Thanks guys,
Found an old Win98 boot floppy and booted with that. fdisk /mbr reset the mbr to just boot straight into Windows, so that worked a treat.
Reinstalled FC4 again. First attempt ended with an error at the end of the data collection phase and before it actually started installing anything. The error was "Error informing the kernel about modifications to partition /dev/hdb1 - Device or resource busy. This means Linux won't know about any changes you made to /dev/hdb1 until you reboot - so you shouldn't mount it or use it in any way before rebooting". I had a choice of ignore or cancel, so clicked cancel, and it displayed another error message saying basically the same thing and telling me I had to reboot. Clicked that and the PC rebooted.
Tried again but this time selected manually partition instead of automatic. Dunno why, but it is using something called LVM for my swap and root partitions. The /boot partition doesn't seem to be in LVM. When the partition screen comes up this is what I see:
VolGroup00
    LogVol00        /           ext3           8608
    LogVol01                    swap          1024
/dev/hda
    /dev/hda1                     ntfs            38154
/dev/hdb
    /dev/hdb1         /boot    ext3           102
    /dev/hdb2         VolGroup00       LVM PV       9664

This time I ensured it would format all partitions, and the install completed successfully. On reboot the PC booted straight into Windows, no grub screen, no nuthin'. Rebooted from FC4 CD1 and entered "linux rescue", then chroot /mnt/sysimage, then grub-install /dev/hda. The response was "/dev/hdb1 does not have any corresponding BIOS drive".
I don't get it. I can successfully install Ubuntu and Mandrake, but not FC4. Ubuntu successfully installs grub (Mandrake installs lilo). But the thing I really don't get is that I have successfully installed FC4 before, grub and everything, not a problem. It's only since I started mucking around with Ubuntu that I can't install FC4 any more.
Would it be a smart idea to change my bios to boot from my slave, (i.e. hdb), instead of the primary, and tell FC4 to install grub to hdb instead of hda? Can I even do that?
Alternatively, can I set up a boot floppy for FC4? I think it might be easier than trying to sort out this conundrum...
Thanks,
Ian

akonstam trinity edu wrote:
On Tue, Sep 20, 2005 at 06:59:02AM -0400, Jim Cornette wrote:
  
Ian wrote:

    
Hi Jim,
Thanks for the response.
My problem is, though, that I can't boot FC4 at all, because grub 
didn't get installed when I reinstalled FC4. The master boot record 
still contains lilo from my install of Mandrake, and it won't boot 
FC4. So I have no way of changing any grub settings. I think they call 
it stuck between a rock and a hard place...
Ian
      
An easy way to wipe out the MBR information is by booting up a startup 
disk for the w9x series OS and typing "fdisk /MBR". This wipes out grub 
or lilo from the master boot record. A DOS boot disk with fdisk on it 
should do the same, using "fdisk /mbr"
XP uses the recovery console and I believe you type fixmbr to clear the mbr.
To clear the MBR in Linux, I don't know how to do this. There is 
probably a utility to clear the MBR somewhere.

Jim
    
Another way to do it is:
dd if=/dev/zero of=/dev/hda bs=1 bc=446 
or:
dd if=/dev/zero of=/dev/hda bs=446  bc=1

But I don't understand why you can't boot with linux rescue, chroot to
your FC4  root partition (chroot /mnt/sysimage) and run grub-install

Obviously hda might be hdb or sda, etc.
  

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]