[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fedora and GNU GRUB



Hi Gregorio,
I had the same problem, see my post "grub doesn't install". I eventually found the problem seemed to be associated with LVM. I had to reinstall FC4 (for about the fifth time...) and when it asked me about partitioning the drive, I chose manual, then deleted everything to do with LVM and partitioned using "normal" partitions. The install finished correctly, grub installed and worked, and I've never looked back. I'm interested to hear how you go with Agnula. I would also like to have a play with it, but the doc only mentions FC1, so not sure if it is compatible with FC4.
Cheers, Ian

Gregorio Canelos wrote:

Jim Cornette wrote:

Gregorio Canelos wrote:

Hello Everyone,

I'm new to fedora core 4 and this list. I got my hands dirty pretty fast, and now I can't get the dirt off...... That is, I somehow ended up in the GRUB command-line after rebooting, after an uninstall of rehmudi packages. I don't know GRUB and can't really follow the GRUB how-to's. . . What's the command to boot up with the linux partition?

Thanks,
Gregorio

If you boot from the rescue disc, it should find your installation. If it finds your Fedora installation, it should mount your installation as /mnt/sysimage and if you have a seperate /boot partition, it will be mounted as /mnt/sysimage/boot. You will be directed by a prompt to run the chroot program with the directory argument as /mnt/sysimage. This will change your directory path to / for /mnt/sysimage and the //mnt/sysimage/boot partition will be /boot. Anyway, you should have the environment of your Fedora installation and can run commands to recover/ reinstall grub to a working stage. If you have ATA drives, running the below command should reinstall grub and get you to where you can boot your system and grub is installed correctly.
grub-install /dev/hda
This installs grub to your Master Boot Record where grub is usually installed.

If I misunderstood your problem, please post more details related to your failure. (Hard drive type, steps taken to install Fedora and how you attempted to uninstall the other programs.)

Jim

I had forgotten that a rescue disc existed, so that never came into my mind. I'm currently in the middle of reinstalling the entire OS, and I chose the option to overwrite the existing linux partition. although time-consuming, this should work right?

About the unintall thing,...I had tried to install the Agnula/Rehmudi packages on top of Fedora Core 4 in order to get some special ALSA and JACK capabilties. I thought Rehmudi would be good, because I know nothing about scripts or configuring sound card stuff, I so thought---have Rehmudi do it.

I logged in as root, mounted the cd, and went to the cd folder in the command-line. I ran the installer, and the window was fine, but during the installation, there all kinds of errors concerning depencies, so the installation was half-succesful. Then, I decided to uninstall Rehmudi, which seemed to work. Upon rebooting, I was placed in the command-line boot-loader. Is this normal behavior when un-installing software packages?

Also, I don't know if Rehmudi is recommended or not.

Thanks!!!!
Gregorio



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]