[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RPM error with PGP 6.5.8 installation





On 9/26/05, Michael A. Peters <mpeters mac com> wrote:
On Mon, 2005-09-26 at 15:09 -0400, FS wrote:

> error: Failed dependencies:
>         libstdc++.so.2.8 is needed by pgp-6.5.8-rsaref658
>
> I googled on this and found some tips to ln -s the current version
> (libstdc++.so.5.0.5) to libstdc++.so.2.8 but that doesn't work too.

Never get around library dependency issues with a symlink.
Versions change for a reason - and using wrong versions of libraries
will often cause problems.

yum provides did not find a match, I'm guessing you are out of luck -
try to find a more recent build.

I even tried to compile the source from the same  website, but it died also giving a spectacular multi-line error message (listed below) which I couldn't make either the head or tail of.

So basically if this doesn't work, I won't be able to use PGP on Linux? (With the exception of GPG of course, which I'll have to look at next)

This was the error message when I tried to run the build.sh that came with the source from http://www.pgpi.org/cgi/download.cgi?filename=pgpsrc658unix.tar.gz

g++ -g -O2 -g  main.o args.o pgp.o getopt.o fileio.o config.o doencode.o dodecode.o lists.o keyview.o keygen.o keyadd.o keyremove.o keyedit.o keyexport.o keymaint.o keysign.o keyrevoke.o more.o groups.o match.o misc.o pgpAcquireEntropy.o pgpLanguage.o ../shared/pgpDiskWiper.o ../shared/pgpClientErrors.o -o pgp -L/usr/local/lib -L../../../libs/pfl -L../../../libs/pgpcdk/unix -L/lib/linux -lPGPui -lPGPsdkNetwork -lPGPsdk -lpfl -lpthread  -lm -lnsl
/usr/bin/ld: cannot find -lPGPui
collect2: ld returned 1 exit status
make: *** [pgp] Error 1

Any help appreciated!!

Faisal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]