[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: SAMBA home directories and SELinux



On Wednesday 28 September 2005 19:13, Stephen Walton wrote:
> I have the usual entry in smb.conf on my FC4 server:
>
> [homes]
>         comment = Home Directories
>         read only = No
>         browseable = No
>
> As an additional wrinkle, home directories on the server are physically
> on /users but get mounted on demand on /home on both the server and on
> client workstations using a typical LDAP/autofs setup.
>
> With SELinux enabled, both smbclient and users on Windows machines fail
> to get access to home directories.  What magic chcon invocation do I need?

Solution 1 (temporary; won't survive a re-boot):

Issue the command:

[root]# setsebool samba_enable_home_dirs=1

Solution 2 (might survive a reboot; I didn't actually try this one):

[root]# setsebool -P samba_enable_home_dirs=1

Solution 3 (survives a reboot):

This is the solution I ultimately settled on. Go to the /etc/selinux/targeted 
directory. Create a text file called booleans.local, and put the 
"samba_enable_home_dirs=1" line in it (without the quotes, of course).

Solution 4 (surives a reboot, but removes all SELinux protection):

Edit /etc/selinux/config. Change the line SELINUX=enforcing to 
SELINUX=permissive or SELINUX=disabled.

I've got same problem earlier and tried the 3 solution from the list above. 
It worked.

Best.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]