[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Error with updating the system



On 9/30/05, Jeff Vian <jvian10 charter net> wrote:
> > > > Resolving Dependencies
> > > > --> Populating transaction set with selected packages. Please wait.
> > > > ---> Package mjpegtools.i386 0:1.8.0-0.lvn.1.4 set to be updated
> > > > --> Running transaction check
> > > > --> Processing Dependency: libmjpegutils-1.7.so.0 for package: transcode
> > > > --> Finished Dependency Resolution
> > > > Error: Missing Dependency: libmjpegutils-1.7.so.0 is needed by package
> > > > transcode
> > > >
> > > I see that livna has transcode 1.0.0-0.lvn.3.3 in their unstable repo since
> > > 28th September, so its obviously being tested out.
> >
> > Then, if mjpegtools depends on a unstable transcode version, it would
> > have been wiser not having made mjpegtools.i386 0:1.8.0-0.lvn.1.4
> > available on the stable repository.
>
> You are reading that backwards.  Transcode depends on libmjpegtools not
> the other way around.
>
> The transcode package installed  specifically requires
> libmjpegutils-1.7.so.0 and since the libmjpegutils library is being
> updated and would remove that file, it fails because doing so would
> break the installed dependency.
>
> This may be a transcode issue for requiring an explicit library file,
> but appears to be related to the installed version, not the
> unstable/testing version.

Thanks, Jeff. Meanwhile, I uninstalled transcode and mjpegtools. Then,
I Installed mjpegtools again and, subsequently, transcode, and the
reported problem of dependencies disappeared.

Paul


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]