[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5 breaks Accelrys InsightII



On Thu, Apr 06, 2006 at 10:57:57AM -0400, Jack Howarth wrote:
>    Thanks for reply. It was as I feared. Unfortunately these stupid
> companies porting SGI software to Linux have a legacy fixation and
> assume they can keep running on Redhat 9 forever. Sadly the software
> was released in 2005 and yet was compiled once again for RedHat 9
> usage.

Even if you compile for RHL9, but the sources aren't broken, it will work
just fine in FC5+.
What does not work in FC5+ is:
1) most of programs/libraries built against glibc 2.0.x, i.e. built on RHL
   5.{0,1,2} or something equivalent, that's more than 8 years old
2) buggy programs that don't include <errno.h> when they are using errno
   or don't include <netdb.h> when they are using h_errno and instead
   declare it themselves.  They are just broken and need to be fixed,
   I think even RHL9 didn't allow you to link such broken programs.
3) programs/libraries that rely on LinuxThreads non-conformance to standards
   (such as hardcode knowledge about the stack layout LT used, or that
   different threads used to have different pids and crap like that)

	Jakub


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]