[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

How to copy a Fedora system?



I've been having problems with a SCSI disk
(I think it is 8 years old)
so I decided to copy Fedora-4 to another SCSI disk
and then upgrade it.
That way I reckoned I would have a workable system, whatever happened.

In any case, I copied one system to a partition on the other disk with
the one-line script:

rsync -auvz --delete --exclude 'proc/' --exclude 'dev/'
        --exclude 'sys/' --exclude 'home/' --exclude 'usr/local' 
        --exclude 'usr/src' --exclude 'opt/' / /mnt/hd/

Anyway, this caused a problem with /dev ,
which is really my question.
It seems that some of the devices in /dev , eg /dev/console ,
must be set up explicitly.
When I added "cp -a /dev /mnt/hd" the new system sort of worked,
but I got a lot of strange messages during the boot.

Looking around, I guessed that the entries in /dev/.udevdb/
might have to be created directly,
but I don't know how one is meant to do this.
I tried copying over the listed entries with "cp -a"
but this again worked by not properly.

So my query is: how exactly should one copy a Fedora system
to another partition?

-- 
Timothy Murphy  
e-mail (<80k only): tim /at/ birdsnest.maths.tcd.ie
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]