[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: I can't run SWAT. Asking for help.



On Tue, 2006-04-11 at 00:26 -0700, Gordon Messmer wrote:
> Ivan Evstegneev wrote:
> > 
> > 1) Locating the SWAT File:
> 
> rpm -ql samba-swat
> 
> In addition to the commands you already used, this will tell you 
> everything associated with swat.
> 
> > ******* here some little "spike" appeared, in my case I can only view 
> >         the man pages for "strings" command but when I tried to run it, I got "command not found".
> >         and 'cause of it I followed the next instruction:
> 
> Oddly, the man page for "strings" is a part of the "man-pages" rpm, 
> rather than the binutils (I think) that contains "strings".
> 
> > ******* but for the /usr/share/samba/swat I got nothing. But when I changed a path to "/usr/share/swat"
> >         it described me all those files listed above. So now you see that the only difference between how-to's paths and mine 
> >         is that I have swat supported files in "/usr/share/swat" folder and not in "/usr/share/samba/swat"... 
> >         Actually I created "samba" folder and copied there swat files... but as you can observe it got no effect.
> 
> You didn't need to do that, and should remove the files that you copied.
> 
> > 4) Enabling SWAT for Use.
> > 
> > ***** So I found my "xinetd.conf" and added the following lines as they
> > asked me:
> 
> The samba-swat rpm contains an xinetd file, which should be 
> /etc/xinetd.d/swat.  You can enable swat with "chkconfig swat on".
> 
> Remove the lines that you added to xinetd.conf, as they may conflict 
> with the file contained in the samba-swat package.
> 
> > ******* Then I opened my firefox and wrote this command:        
> >         "http://localhost:901/"; but it didn't work...
> 
> It will after you remove the section you added, and use "chkconfig" to 
> enable swat. :)
> 
> 

Gosh!!!!!! I've spend the whole night over this damn tool and finally it
solved in such easy way!! Hey, Gordon where have you been before?!!
kidding.... Thanks pal!!! Now I realized my mistake, I just tried all
this time to modify "xinetd.conf" instead of "swat" binary file (I'm
right?, Is it binary or it is a conf file of "swat"? in such case why it
comes without "*.conf"? Does it necessary? It is marked as "plain text
document") in "/etc/xinetd.d" folder!!!!
Let me ask me ask you more question: what is about the file I have
in /usr/sbin/swat folder? Is this the binary file? At least it marked as
"executable" on it.

I guess I have some up side down picture.

One more thing: "chkconfig swat on" enables loading this process at the
start up? If no, how do I enable it?

Regards.

Ivan.  


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]