[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: WiFi not working on Dell Inspiron 6400 - and now on Samsung Q35

>Adam Jocksch wrote:
>> I've recently gotten a Dell Inspiron 6400 and installed FC5 on it, but I 
>> can't get WiFi working on the Intel Pro/Wireless 3945ABG card. I've 
>> tried installing the ipw2200 firmware as has been suggested on the list 
>> before, but with no success.
>You want to use the ipw3945 firmware, module, and regulatory daemon.
>See ipw3945.sf.net for details.  I have a Dell E1705/9400 and this has
>been working fine for me on FC4 combined with wpa_supplicant.  I
>haven't tried the 0.0.71 release from a few days ago, but I've had the
>0.0.70 release with patches going well since it's release.
>I've yet to update to FC5 to see how well (if at all) I can make this
>setup integrate with NetworkManager.

I am running FC5 on a Samsung Q35 - which has an IPW3945.  I have installed the
ieee80211 version 1.1.13 subsystem, and also the ipw3945 driver version 0.0.73
from sourceforge, along with the microcode and regulatory daemons.

I prepared an ifcfg-eth1 file in the /etc/sysconfig/network-scripts directory.

I find that if I run the "load" script provided in the ipw3945-0.0.73 directory
then the wireless interface fires up beautifully.

I can shut down the interface with ifdown eth1.

However I cannot make the daemon/module load automatically via the modprobe.conf
alteration suggested in the INSTALL file.

In the INSTALL file it suggests that there should be two lines:
       # echo install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; \
sleep 0.5 ; /sbin/ipw3945d --quiet >> /etc/modules.d/ipw3945

        # echo remove ipw3945  /sbin/ipw3945d --kill ; \
/sbin/modprobe -r --ignore-remove ipw3945 >> /etc/modules.d/ipw3945

However I presume that the "# echo" and the ">> /etc/modules...." are not
required as this makes the system fail to boot, so I put the two lines into the
modprobe.conf file as

install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; \
sleep 0.5 ; /sbin/ipw3945d --quiet

remove ipw3945  /sbin/ipw3945d --kill ; \
/sbin/modprobe -r --ignore-remove ipw3945

However the ipw3945 module and daemon are not loaded after boot - and ifup eth1
do not work either.   I also added a line to the modprobe.conf as 
alias eth1 ipw3945

even though this was not mentioned in the INSTALL file - but this also does not

I also tried adding to the first modprobe.conf line /sbin/modprobe -q eth0 in
case the known bug in FC5 prevents the system from assigning the correct device
name but this also has no effect.

If I try ifup eth1 after booting the terminal message is:
"ipw3945 device eth1 does not seem to be present, delaying initialisation"

I am using the 2.6.15-1.2054_FC5smp kernel - 

Does anyone know how to get this to work so that it knows about the wireless
interface after bootup ?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]