[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5 install hangs before disk format



On Fri, 2006-04-14 at 02:28 -0700, Justin Zygmont wrote:
How much RAM do you have?  what amount of packages did you select?  Will 
it work using "minimum install"?


On Thu, 13 Apr 2006, Cyrus A wrote:

> I've tried installing FC5 about a dozen times over the past couple of days, 
> but to no avail. I'm using the FC5 x86_64 DVD and installing on an nforce4 
> AMD 64 X2 3800 processor architechture.
>
> On the GUI install page reading "Fedora core 5 is ready for installation. 
> Click OK to continue", I click OK. The big screen-wide progress bar appears 
> but the system simply hangs. I know from experience that the next thing that 
> is supposed to happen is the / filesystem is formatted, but the little window 
> never comes up. The DVD simply spins down and the system hangs forever.
>
> Any thoughts?
>
> Cyrus
>
> p.s. I'm using 4 SATA drives, but I have tried disconnecting all but one and 
> still get the same problem. I have tried my DVD drive in both the secondary 
> and primary IDE channels.
>
>

I had a similar problem install on my system that previously had FC4 on PATA disk:-

ASUS A7V8X
Athlon 2200+
1GB RAM
NEC DVD_RW ND-3520A

This system has PATA and SATA ports and since my PATA disk had failed I decide to try using the SATA with a pair of WDC WD1600SD-01K drives.

The SATA ports on this motherboard are via a Promise PDC20376 Raid chip.
The only way this motherboard can boot the SATA drives is to have them defined as a RAID 0/1 in the BIOS. They are not bootable as single disks. 

My first attempts installing FC5 with the BIOS defining a RAID 0 resulted Anaconda finding   "/dev/mapper/pdc_fiagfhab" but at the point os selecting to use it Anaconda would report it can't access "/dev/mapper/pdc_fiagfhab" then go on to allow selection of software packages then hang when it should be formatting.

Since I had no knowledge of what was causing the problem and whether some other aspect of my system were casing a problem with FC5 I added a small PATA disk (20GB) on IDE0 and defined the pair of SATA drives as single  disks (no BIOS RAID defined).

I was then able to install FC5 using the PATA disk as /boot and boot MBR I defined the two SATA drives as FC5 LVM2 RAID 0.

While installing the system would still hang at point of going to format but would report:-

"Can't write to /media/cdrecoder please close any other terms you have open" !!

I found if I looked at the release notes, hence spinning the CDROM up before clicking continue thus exiting package selection it would generally proceed without getting the message above.
In fact I found I can to select the basic workstation with no customisation still looking at release notes to get the system installed. I left package select till the system was installed. 

FC5 finally came up with the /dev/mapper/VolGroup00-LogVol00 on the pair of SATA drives but booting off the PATA drive.

I decided to have another go at installing on the SATA drives while defined in the BIOS as a RAID 0 so I could boot them. I can only think having formatted them first as LVM2 RAID 0 help them be recognised by Anaconda when installing with them defined in BIOS as RAID 0?

This time although the same at the first attempt, it found  "/dev/mapper/pdc_fiagfhab" and this time didn't report it could access it. Again going for the default minimum workstation install and reading release notes to spin CDR up install work and FC5 now booted with MBR on SATA1

It was still the case if while installing I went for package customisation or select more than the minimum it would still hag before formatting even if I looked at the release notes  at last minute?

NOTE all CDR install disk were checked before any installing was attempted so it was not a media problem.

Anyway FC5 is now running fine with only the pair of SATA drives defined as a RAID 0 on the Promise PDC20376 Raid chip.

So I had considerable problems with FC5 installing hanging but after 8 hours of different attempts of installing FC5 now runs stably.

Hope my experience might help you proceed with an install

--Andrew Gray






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]