[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: spca5xx freezes system



On 4/16/06, tiger <no-reply-gw fcp homelinux org> wrote:
> 2.6.16-1.2080_FC5smp
> gcc (GCC) 4.1.0 20060304 (Red Hat 4.1.0-3)
> spca5xx-20060402
>
> Compiles and installs fine. Modprobe spca5xx works fine. Here's the /var/log/messages output of doing a "modprobe spca5xx":
>
> Apr 16 12:18:39 electron kernel: Linux video capture interface: v1.00
> Apr 16 12:18:39 electron kernel: usbcore: registered new driver spca5xx
> Apr 16 12:18:39 electron kernel: /root/spca5xx-20060402/drivers/usb/spca5xx.c: spca5xx driver 00.57.11 registered
>
> Next, I plug in the camera, and /var/log/messages gives:
>
>
> Apr 16 12:20:33 electron kernel: usb 1-2: new full speed USB device using uhci_hcd and address 4
> Apr 16 12:20:33 electron kernel: usb 1-2: configuration #1 chosen from 1 choice
> Apr 16 12:20:33 electron kernel: hub 1-2:1.0: USB hub found
> Apr 16 12:20:33 electron kernel: hub 1-2:1.0: 4 ports detected
> Apr 16 12:20:34 electron kernel: usb 1-2.4: new full speed USB device using uhci_hcd and address 5
> Apr 16 12:20:34 electron kernel: usb 1-2.4: configuration #1 chosen from 1 choice
> Apr 16 12:20:34 electron kernel: /root/spca5xx-20060402/drivers/usb/spca5xx.c: USB SPCA5XX camera found. Type Creative Live! Zc301+Tas5130c
> Apr 16 12:20:34 electron kernel: /root/spca5xx-20060402/drivers/usb/spca5xx.c: [spca5xx_probe:8301] Camera type JPEG
> Apr 16 12:20:35 electron kernel: /root/spca5xx-20060402/drivers/usb/zc3xx.h: [zc3xx_config:530] Find Sensor HV7131R(c)
> Apr 16 12:20:35 electron kernel: /root/spca5xx-20060402/drivers/usb/spca5xx.c: [spca5xx_getcapability:2198] maxw 640 maxh 480 minw 176 minh 144
>
> But when I run spcaview, it freezes the machine. For obvious reasons I can't cut-n-paste the screen output. Any ideas?

Same problem here with FC5 & spca5xx on a Biostar motherboard.  I had
a serial console setup, and saw some crazy kernel Oops everytime.  I
emailed the spca5xx maintainer and he blew me off initially stating
that he only supports official kernel.org kernels.  So I built an
official 2.6.16.1 kernel, and saw the same exact Oops all over again
(plus on my system it just spontaneously reboots, instead of hanging).
 Now the maintainer is just ignoring my emails, which leads me to
believe that he doesn't know how to fix the problem.  *sigh*


--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
L. Friedman                                    netllama gmail com
LlamaLand                       http://netllama.linux-sxs.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]