[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Missing Dependencies [monodevelop]



On 21/04/06, Ali Helmy <alihelmy gmail com> wrote:
On 21/04/06, PFJ < paul all-the-johnsons co uk> wrote:
Hi,

> I am trying to install monodevelop, so I undertook the following
> steps:
>
> A) I downloaded and run the mono-project installer from the mono
> website, which completed successfully

If you're using FC5, it's not a good idea to use the installer. Use the
rpms supplied with FC5 for mono and grab the rest from my website
( http://www.all-the-johnsons.co.uk/mono/rpms.html - if you're using
x86_64, they may not work)

I've listed the rpms you need. In addition, I'd grab gtk-sharp2-gapi

> Error: Missing Dependency: mono(glib-sharp) = 2.4.0.0 is needed by
> package monodevelop

IIRC, gtk-sharp2

> Error: Missing Dependency: mono( Boo.Lang) = 1.0.0.0 is needed by
> package monodevelop

boo

> Error: Missing Dependency: mono(gdk-sharp) = 2.4.0.0 is needed by
> package monodevelop

gtk-sharp2

> Error: Missing Dependency: mono(pango-sharp) = 2.4.0.0 is needed by
> package monodevelop

gtk-sharp2

> Error: Missing Dependency: mono(monodoc) = 1.0.0.0 is needed by
> package monodevelop

monodoc

> Error: Missing Dependency: mono(Boo.Lang.Parser ) = 1.0.0.0 is needed
> by package monodevelop

boo

> Error: Missing Dependency: mono(Boo.Lang.CodeDom ) = 1.0.0.0 is needed
> by package monodevelop

boo

> Error: Missing Dependency: mono(gconf-sharp) = 2.4.0.0 is needed by
> package monodevelop

not sure

> Error: Missing Dependency: mono(Boo.Lang.Interpreter ) = 1.0.0.0 is
> needed by package monodevelop

boo

> Error: Missing Dependency: mono(glade-sharp) = 2.4.0.0 is needed by
> package monodevelop

gtk-sharp2

> Error: Missing Dependency: mono(gnome-sharp) = 2.4.0.0 is needed by
> package monodevelop

gtk-sharp2

> Error: Missing Dependency: mono(Boo.Lang.Compiler ) = 1.0.0.0 is needed
> by package monodevelop

boo

> Error: Missing Dependency: mono(gtk-sharp) = 2.4.0.0 is needed by
> package monodevelop

gtk-sharp2

> Error: Missing Dependency: mono(gnome-vfs-sharp) = 2.4.0.0 is needed
> by package monodevelop

gtk-sharp2

> Error: Missing Dependency: mono(gtkhtml-sharp) = 2.4.0.0 is needed by
> package monodevelop

gtkmozembed (IIRC)

> Error: Missing Dependency: mono(gtksourceview-sharp) = 1.0.0.2 is
> needed by package monodevelop

gtksourceview-sharp

TTFN

Paul
--
"Logic, my dear Zoe, is merely the ability to be wrong with authority" -
Dr Who

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Ok, great... now I will do an un-install of all those I have installed with yum, so that I can start a clean install with what you've said...

Thanks, I'll keep you posted to what happens


--
Cheers,
     A. Helmy
==================
  One Life... LIVE It
==================

Hey mate,

I un-installed everything using the mono uninstaller, and removed all the packages i had added manually... now I downloaded all the packages from your website, and installed them with rpm and they worked fine... I then installed monodevelop and it also works fine...

However, when I try installing your gtksourceview-sharp package, i get:
rpm -ivh gtksourceview-sharp-2.0-4.i386.rpm
Preparing...                ########################################### [100%]
        file /usr/share/gtksourceview-1.0/language-specs/vbnet.lang from install of gtksourceview-sharp-2.0-4 conflicts with file from package gtksourceview-1.6.1-1.fc5.1

Yet, monodevelop is working fine, so is this something I dont need to bother with, or what should I do?

--
Cheers,
     A. Helmy
==================
  One Life... LIVE It
==================
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]