[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Firefox Acroread plugin not working



On Sun, 23 Apr 2006, Gene Heskett wrote:

On Sunday 23 April 2006 19:14, Kam Leo wrote:
On 4/23/06, Gene Heskett <gene heskett verizon net> wrote:
On Sunday 23 April 2006 17:17, Matthew Saltzman wrote:
On Sun, 23 Apr 2006, Gene Heskett wrote:
On Sunday 23 April 2006 13:36, Lauri wrote:
# chcon -t texrel_shlib_t
/usr/local/Adobe/Acrobat7.0/Reader/intellinux/lib/*.so

Lauri

Thank you very much Lauri, that worked like a champ.  But why
does it seem to be such a huge secret other than its ulitmately
being usefull to the blackhats?

I assume that this command line (the top line above) can be used
against any other known good (we think) but similarly
malfunctioning (the bottom line above) program?

Yes, if you are sure that's the malfunction.  The binary NVIDIA
driver's GLX and VMWare Workstation are the other examples I know
of. Are there others?

That question is rhetorical I assume as we won't know till it bites
us again if there are any others.  But it does tend to show just how
much committment Adobe has in supporting linux.  Their test box is
probably still running rh6.1...

Gene, how is Adobe responsible for a problem caused by Red Hat /
Fedora Core developers? You are using essentially the same version of
Acrobat Reader that worked without problems for Fedora Core 4. It is
not Adobe's fault that the Red Hat / Fedora Core  implementers of
SELinux changed the rules after Acrobat Reader 7 was released. If you
have a bone to pick, take it up with the responsible party.

Well now, I *thought* that was what I was doing in posting to this list.
and the fix did eventually come from here, no doubt deciphered by
someone intimatly familiar with selinux and the errors it may cause to
be thrown.  As a new user to selinux, how would I have recognized that
error when the docs are so limited, literally one page, 1/3 of which is
credits.

But it appears the fix is to request that Adobe include that command in
the rpms post-install script, so I have also requested that of Adobe.

AIUI, the fix is to get Adobe to rebuild the library so that it doesn't require that command. The fedora-selinux-list archives have an explanation, which you might want to pass on in your bug report.

To be fair to Adobe, I think this type of protection is new in FC5's SELinux policy.


Applying logic, there isn't a whole lot the FC release crew could have
done or would need to do to alleviate it once the nature of the problem
was known.  It is not their code to be responsible for, its Adobe's, so
if they want it to run on an as installed FC5 box, which it should,
then its up to them to fix it IMNSHO.

Is this the wrong attitude on my part?



--
		Matthew Saltzman

Clemson University Math Sciences
mjs AT clemson DOT edu
http://www.math.clemson.edu/~mjs


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]