[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: USB thumb drive questio



Stephen Liu wrote:
> Hi Mikkel,
> 
>> I find it strange that any drive of that size can not be formatted
>> FAT32. 
> 
> I'm equally unresolved.  These 2 USB thumb drives can't be formatted as
> FAT 32.  I tried many times in past on FC3 box running;
> 
> - fdisk to set the FS as FAT32 and then formatted it with vfat
> - mkfs -t FAT32
> 
> "fdisk -l" only showed them as FAT16.  Would fdisk can't recognize
> FAT32?
> 
I would have used "mkfs.vfat -F 32", "mkfs.msdos -F 32" or
"mkfs -t vfat -F 32".

>From "man mkfs":
mkfs is simply a front-end for the various file system builders.

I am not sure what it tried to do when you used "mkfs -t FAT32"
because that does not look like a valid option to me...

You need the "-F 32" option if you want to format to FAT32.

-F FAT-size
   Specifies  the type of file allocation tables used (12, 16 or 32
   bit).  If  nothing  is  specified,  mkdosfs  will  automatically
   select  between  12  and  16  bit,  whatever fits better for the
   filesystem size.  32 bit FAT  (FAT32  format)  must  (still)  be
   selected explicitly if you want it.

Also, mkfs.vfat and mkfs.msdos are really links to mkdosfs.
> 
>> I could see where the BIOS might have a problem if it is
>> looking for a specific signature at the start of the drive. I would
>> think you could get around it for Grub by installing to the boot
>> record of the active partition instead of the MBR. 
> 
> Could you pleae explain in more detail how to make it?  Tks.
> 
> 
For a new install, you would use "grub> setup (hd0,0)" instead of
using "grub> setup (hd0)" or select the option to install to the
boot record of the root partition instead of the MBR. (I don't
remember the exact wording of the option in the installer.)

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]