[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Dillo-dev] Dillo 0.8.5-2.fc5 suddenly having problems as default browser under FC5



On Tue, 25 Apr 2006, Francis Daly wrote:

On Mon, Apr 24, 2006 at 05:35:15PM -0400, beartooth wrote:

As far as I can see, dillo-0.8.5-2.fc5 dates from April 5th, while dillo-0.8.5-1.fc5 dates from March 4th.

The main difference between the two is the addition of the dillo-0.8.5-i18n-misc-20060105.diff.bz2 patch into the new version.

So, if you've been updating reasonably frequently, then it may be safe to guess that things worked with dillo-0.8.5-1.fc5 and fail with dillo-0.8.5-2.fc5?

Most probably; there is often a discernible lag between the appearance of any new version of an app and its arrival in the Fedora repositories for yum.

You can possibly demonstrate that this is the case by downgrading to dillo-0.8.5-1.fc5 and seeing if it works as it used to.

For the first time in my experience, I'd like to try -- but I have no idea how to downgrade anything. Is there a "yum downgrade" command?? I could get an rpm, I'm sure; but I'm a little uneasy about doing rpm -f, or for that matter anything as root with an -f switch.

If I open Dillo from its icon in the browser drawer on my panel, it tells me "Welcome to Dillo 0.8.5-i18n-misc" -- but rpm -q dillo says dillo-0.8.5-2.fc5.

Yes, that's the patched version. I believe the splash screen has some hints for problem reports.

Maybe it used to; I disremember. What I get by launching it now is a thing like a miniature icon on the desktop: a round-topped vertical blue rectangle with a white bottom, half the size of my little fingernail. The cursor, touching it, immediately turns into a double-tipped diagonal with which to drag to corner to resize it. That done, it says "about:splash" in the location bar, and "Welcome to Dillo 0.8.5-i18n-misc" on the gray background.

The rest looks like a drawing of tables of words, with just lines to represent phrases.

View > Options gives a screen called Dillo Preferences -- which is new and welcome to me, but, alas!, doesn't work.

On the Interface tab, resetting panel size may do something; can't tell. Setting window size up to 1000 x 700 gets me something that might be of use (on a ViewSonic VG91-b 19" flat panel LCD monitor, 1280 x 1024) -- but I still see nothing remotely readable where text looks meant to be.

The font tab comes up with "font factor" (something I never heard of) set to 0.1; I just reset to 1.5, and now see text. Better let me play around a while -- this is beginning to remind me of RH/Fedora's bad old days, when any app came up requiring configuration before first use -- not only no usable defaults out of the box, but no defaults at all. PLEASE do not go back to that!

If you can give a recipe for reproducing any of the problems with vanilla dillo, I'll take a look into it.

Now that I can see something I can read, I'd better play around a while, to see what I can see, and then report.

For me (not on FC5):

$ ./dillo --version
Dillo 0.8.5
$ ./dillo www.dillo.org

	Tried that both as user and as root; got the same both ways :

bash: ./dillo: No such file or directory

happily opens http://www.dillo.org

That still gives me ERROR: unable to connect to remote host. I'll go look at it on another browser.

	Stay tuned.
--
Beartooth Staffwright, Neo-Redneck Linux Enthusiast
A wanderstaff like an Elvish rope should be long,
and strong, and light. And gentle to the hand.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]