[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: wifi pcmcia card only works if inserted after booting FC5



On 4/23/06, Sam Varshavchik <mrsam courier-mta com> wrote:
Lonni J Friedman writes:

> On 4/23/06, Peter Gordon <peter thecodergeek com> wrote:
>> Lonni J Friedman wrote:
>> > This card uses the orinoco_cs driver, however for some bizarre reason
>> > the hostap_cs driver is also getting loaded, even though its never
>> > used.
>>
>> The hostap_cs driver might be "hogging" the card (for lack of better
>> wording). You might want to try adding that to your
>> /etc/modprobe.d/blacklist file.
>
> Sorry, forgot to mention, I've tried that already too.  It makes no difference.

Explain.  If hostap_cs still gets loaded, you must've made a typo in the
blacklist file.  If hostap_cs does not get loaded, you need to keep digging.

Although I have no specific knowledge of these drivers, I have been hacking
the startup scripts recently, so there are a couple of things worth trying.

Create a new file in /etc/modprobe.d, containing:

install orinoco_cs /bin/true

This'll keep kudzu from loading the module immediately after the kernel
initializes.  This is just a temporary thing -- this'll also keep hotplug
from loading the module if the card is inserted when the system is running.
You just want to check if by preventing the module from getting loaded on
early in the boot process, and when the system is done booting, if a
"modprobe -i orinoco_cs" brings the card up.  If so, there might be
something in the early boot environment that keeps the module from coming up
correctly.

Finally had time to try this out.  Adding the entry you suggested
definitely prevented the card from being detected.  Unfortunately,
running "modprobe -i orinoco_cs" doesn't seem to work properly.  The
module loads without errors, however the eth1 interface doesn't come
up.  Attempts to bring it up manually (ifup eth1) fail with:
Device eth1 does not seem to be present, delaying initailization

Worse, the hostap_cs module seems to take ownership of the card
instead, and it blows up miserably with all kinds of errors about
"interrupt delivery does not seem to work"

I also tried adding hostap_cs to /etc/modprobe.d/blacklist (with the
changes above) and that didn't help either, as udev (or perhaps
something buried in the pcmcia code in the FC5 kernel) still insists
on trying to bring up a wifi0 interface for the blacklisted hostap_cs
module (which still got loaded anyway).

This really really sucks.  Any other ideas?

--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
L. Friedman                                    netllama gmail com
LlamaLand                       http://netllama.linux-sxs.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]