[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum: No module named rpm



Hi all,

I was trying to upgrade fc4 from fc3 through yum

this is what I did:

1. I downloaded fedora-release package from fedora site
2. rpm -Uvh fedora-release-4-2.noarch.rpm
3. yum update

And I rebooted my pc

I tried 'yum update' again,
I noticed something dependency or obselete message kernel-utils
I removed all kernel*-fc3 packages and kernel-utils too
I installed hardlink-fc4

and then after problem began
whenevr I run yum or 'yum update', I get:

======================

There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   No module named rpm

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.1 (#1, May 16 2005, 15:19:29)
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)]

If you cannot solve this problem yourself, please go to
the yum faq at:
  http://wiki.linux.duke.edu/YumFaq

========================

Please help me to fix this issue,

--
You don't have any choice, you already made it before you came here.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]