[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum update yum ERROR ?!



Luciano Costa wrote:
> I tried to do a yum update and when it is processing shows the message
> below:

Not sure about the traceback...

Looks like you've got a pretty odd system there.

Taking these out of order...
> --> Processing Conflict: hal conflicts kernel< 2.6.11

You still have kernels less than 2.6.11 installed. Has this system been
upgraded from Fedora Core 3? (If so, how?)

Run
rpm -q kernel
to check which versions you have,
uname -a
to check that you're currently on a later version,
and
rpm -e kernel-2.6.10-whatever
to erase the older kernels.

> --> Processing Dependency: libnewt.so.0.51 for package: kudzu
> --> Processing Conflict: kernel conflicts isdn4k-utils< 3.2-32
yum update isdn4k-utils
or
yum remove isdn4k-utils
(do you use ISDN?)

> Traceback (most recent call last):
>   File "/usr/bin/yum", line 8, in ?
>     yummain.main(sys.argv[1:])
>   File "/usr/share/yum-cli/yummain.py", line 104, in main
<snip>

First of all,
rpm -q yum rpm-python python
Do you have the latest versions? My system shows
yum-2.4.1-1.fc4
rpm-python-4.4.1-22
python-2.4.1-2

You may want to upgrade these first. Or you may want to solve the
dependancy issues and upgrade all together.

Hope this helps,

James.

-- 
E-mail address: james | 'Short for "Sic Transit Gloria Humanorum", which is
@westexe.demon.co.uk  | Latin for "There goes the neighbourhood!"'
                      |     -- Menno Willemse


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]