[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: iPod on Linux?



On Sun, 2006-02-12 at 10:51 +0100, Alessandro Brezzi wrote:
> 2006/2/12, Michael Fleming <mfleming enlartenment com>:
>         My 1GB iPod Shuffle is picked up instantly by FC (more
>         reliably than
>         Windows XP, oddly ;-)) and I've used the gtkpod RPM from
>         freshrpms.net
>         without a hitch.
>         
>         Michael.
> 
> ... have you tried amaroK? Just curious about that.

amaroK sees the iPod just fine

Here's a few things from my experiences with the iPod and Linux.

At first I didn't knew how to get the "Do not disconnect" screen off the
iPod so I had to disconnect it after just unmounting the iPod (and it
might have been disconnected without any unmounting also) and about a
week or 2 after I got the iPod the filesystem had errors. I thought I
would have to reformat it but just running fsckdos on it did the trick.

Also later I found out that to get the "Do not disconnect" screen to go
away you have to eject the ipod but you need to be root to do it. The
other day I was looking on the web to see if it was the same thing with
other distros and it seem some other distro (I don't remember which) has
eject suid root so I thought I'd try that and now I can just eject the
ipod from the desktop. Not sure how safe putting eject suid root is but
I'm the only user on this computer and that's a risk I'm willing to
take.

Also I had installed gtkpod 0.94 which I compiled myself on one computer
which I initially used to copy my songs on the iPod, then found out that
livna had gtkpod 0.93 I think, so I installed it on my other computer
but I wasn't able to read the iTunesDB with it so I had to recompile
0.94 for the other computer also. I now upgraded to 0.99.2 and haven't
had any issues. Also one more thing with gtkpod I belive the default
ipod mount point is /mnt/ipod in it so make sure that's changed
to /media/ipod so it can find the iPod.

Now playing songs, I use Rhythmbox, at first I was just importing the
whole iPod directory but it always took a long time to check for new
songs whenever I opened Rhythmbox and Rhythmbox has iPod support but
it's just not compiled in in Fedora. So I decided to give it a try, I
recompiled Rhythmbox with iPod support only to find out why it hasn't
been compiled in. It just crashed whenever I tried to access the iPod.
So I decided to try a newer version, I got the SRPM from rawhide and
recompiled it for FC4 (didn't work right away I had to do some
modification to the spec file). Now Rhythmbox finds the iPod right away
and I can play the songs directly from the iPod. I believe FC5T2 has
iPod support already compiled in in Rhythmbox so FC5 should have it
also.

I also gave amaroK a try since it seems to be quite popular. But I
didn't find it as easy as with Rhythmbox (with iPod support) to just
plug it in and play songs right away. But it works fine, it finds the
iPod and all the songs are there and you can play them, I don't remember
if you can play them directly or you need to drag the songs in the
"playlist" or whatever.

So now my iPod works "perfectly", I can just plug it in, open Rhythmbox
and play songs and when I'm done, I just close Rhythmbox, unmount the
iPod and disconnect it.

The only thing that's missing is the ability to add songs, edit song
information and edit playlists directly from Rhythmbox so I wouldn't
need gtkpod anymore.

-- 
Jean-Rene Cormier <jrc jrcormier com>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]