[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: apcupsd lock file error



Anthony Messina wrote:
john bray wrote:

On Sun, 2006-02-12 at 16:51 +1000, david walcroft wrote:

Hi,
  Would anyone tell me what needs to be done to fix this lockfile

Sun Feb 12 16:19:04 EST 2006 Valid lock file for pid=2296, but not ours pid=21621 Sun Feb 12 16:19:04 EST 2006 apcupsd FATAL ERROR in apcdevice.c at line 77
Unable to create UPS lock file.
Sun Feb 12 16:19:04 EST 2006 Valid lock file for pid=2296, but not ours pid=21621
Sun Feb 12 16:19:04 EST 2006  apcupsd error shutdown completed
Sun Feb 12 16:20:38 EST 2006 Valid lock file for pid=2296, but not ours pid=21942 Sun Feb 12 16:20:38 EST 2006 apcupsd FATAL ERROR in apcdevice.c at line 77
Unable to create UPS lock file.
Sun Feb 12 16:20:38 EST 2006 Valid lock file for pid=2296, but not ours pid=21942
Sun Feb 12 16:20:38 EST 2006  apcupsd error shutdown completed

I can't find "apcdevice.c" it's probably a binary and I'm hopeless at binary.
But 'ls /var/lock/subsys/apcupsd' exists.


  Thanks   david


david - i'll bet you have selinux turned on.  set it to non-enforcing
mode.  there's always been a problem with apcupsd and it's lock file
with selinux.

john


wait now. don't just disable selinux. that would be a workaround, not a solution. besides, there are plenty of us running apcupsd with selinux enabled with no lock problems. john summerfield wrote a good way of trying to track the problem down in his previous post. kill apcupsd, then delete the lock file from the /var/lock/subsys dir and start apcupsd using the startup script ~#] service apcupsd start

then tell us what happens.

Ok,
I did as suggested by john summerfield, stopped apcups,delete the lockfile,start apsups again,this error is the result of"apctest" --


[david reddwarf ~]$ apctest


2006-02-13 14:39:49 apctest 3.12.1 (06 January 2006) redhat
Checking configuration ...
Attached to driver: usb
sharenet.type = DISABLE
cable.type = USB_CABLE

You are using a USB cable type, so I'm entering USB test mode
mode.type = USB_UPS
Setting up the port ...
apctest FATAL ERROR in linux-usb.c at line 649
Cannot find UPS device --
For a link to detailed USB trouble shooting information,
please see <http://www.apcupsd.com/support.html>.
apctest FATAL ERROR in linux-usb.c at line 649
Cannot find UPS device --
For a link to detailed USB trouble shooting information,
please see <http://www.apcupsd.com/support.html>.
apctest error termination completed

I have SELinux disabled at the moment so I'll enable it and try again.

  Thanks   david



















[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]